No announcement yet.

Exchange Queues - (Blocking SPAM Queues)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange Queues - (Blocking SPAM Queues)


    Firstly hello to everyone on the forums.

    I am hoping someone might be able to point me in the right direction or help me to resolve a problem I am experiencing on our exchange server. I should mention that I am a novice user when it comes to exchange and this is my first week using it. (Started New Job)

    We have a number of Queues with lots of SPAM e-mails, at this time I have put a freeze on them and I am currently going through and trying to remove them a few at a time but it keeps crashing out.

    I would like advice on the following;

    1) Is there a command line I can use to delete an entire queue? (e.g.
    I have seen aqadmcli.exe (Click Here) but from my understanding this will delete everything?

    2) Can I setup filters to prevent e-mails from these address entering the outgoing queue again?

    E.g. if I say any outbound e-mail for ( delete?

    The Queues marked in red below are some of the ones I wish to delete

    Any time and help users can offer would be very much appreciated


  • #2
    Re: Exchange Queues - (Blocking SPAM Queues)

    Just to clarify, are these emails coming INTO your network, or OUT from your network?
    ** Remember to give credit where credit is due and leave reputation points where appropriate **


    • #3
      Re: Exchange Queues - (Blocking SPAM Queues)

      This is the procedure to clear the queue but you should check first that any relaying is turned off, even authenticated users and the localhost.

      I used my existing SMTP connector and modified instead of creating a new connector. Then I changed it back after.

      I had a similar problem with authenticated POP3 users being allowed to relay but I killed that and went with RPC over HTTPS.

      1. In ESM, Connectors, Right click on connectors and choose New, SMTP Connector.

      2. On the "General Tab" type a name for the connector. "Spam Cleanup" or similar.

      3. Click the "Add" button under "Local Bridgeheads" and choose your Exchange server.

      4. Click on the "Address Space" tab.

      5. Click "Add" and choose SMTP. Leave each setting (* and cost of 1) and press ok.

      If all the spam is to one domain, then you could remove the * and enter the domain that the messages are being sent to. This should leave legitimate messages in the queue.

      6. Click on the General tab again. Change the option in the centre from DNS to "Forward all mail through this connector to the following smart hosts".

      7. Enter an invalid IP address in square brackets: [].

      8. Click on the "Delivery Options" tab and ensure that "Specify when messages are sent through this connector" is selected.

      9. Change the option to 11pm. (If it is close to 11pm when you are doing this, use a much earlier time - 6am or similar. The time doesn't matter as long as it is not close).

      10. Press Apply/OK to close the SMTP Connector dialogue.

      11. Restart SMTP Virtual Server.

      12. Expand Servers, <your server>, Protocols, SMTP.

      13. Right click on the "Default SMTP Virtual Server"

      14. Choose "Stop". This may take a few minutes.

      15. Once it has stopped, right click again and choose "Start".

      This will place all the e-mail in all the connectors in your queue into one connector in the queue. You can then go into the connector, select all the messages and delete them.
      Network Engineers do IT under the desk


      • #4
        Re: Exchange Queues - (Blocking SPAM Queues)

        That looks like your server is being abused. Either an open relay or NDR spam.
        I would suggest that you take a look at my spam cleanup article:

        That will help you identify the source of the problem and clean it up.

        Last edited by Sembee; 16th August 2011, 09:49. Reason: URL Correction
        Simon Butler
        Exchange MVP

        More Exchange Content:
        Exchange Resources List:
        In the UK? Hire me:

        Sembee is a registered trademark, used here with permission.