Announcement

Collapse
No announcement yet.

Exchange 2000 resends old e-mails at reboot

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • nsumner
    started a topic Exchange 2000 resends old e-mails at reboot

    Exchange 2000 resends old e-mails at reboot

    I have a stragne problem with an Exchange 2000 server. Everytime it reboots it tries to send out hundreds or even thousands of e-mails that were undelivarable at the time of sending. It is normally e-mails that were sent in a mass mailing that my user decided to include an image in (like Rosh Hashanah cards to 5000 people).

    It slows the server down and starts re-sending them. How can I prevent this from happening in the future and what exactly is causing it to do this. Where are these e-mails before the reboot (IE can I manually delete them before a reboot?).

    P.S. We are currently running Exchange 2000 with NO Service Packs (I will be installing SP3 in the upcoming week).

  • nsumner
    replied
    Well I understand this is "normal behaviour" we are talking about MONTH old or more e-mails well beyond a 2 day 3day or even 1 week window.

    Leave a comment:


  • guyt
    replied
    This is a normal behavior.

    The RFC 1123 states that SMTP server must try to resend messages in the case of delivery failure.
    By default Exchange will try to resend failed messages every 15 mins and will quit after 2 days.
    (actually first 3 tries are in 10 minute interval). RFC recommends 30 minutes for retries and 4-5 days to quit on the delivery of the message.

    i.e.: I send message to [email protected], but SMTP server responsible for domain.com is currently down. Exchange will retry to send the message every 15 minutes and will quit after 2 days (and will send me back NDR - "Non-Deliverable Recipient" message telling that it tried to reach [email protected] and failed.

    More details about the correct protocol behavior can be found here:
    http://www.freesoft.org/CIE/RFC/1123/107.htm

    You can tune the resend interval in the SMTP settings, but Exchange will try to deliver the email after the reboot in any case.

    Leave a comment:


  • Dumber
    replied
    first,
    install the servicepacks asap.

    second why not limiting the max messages?

    Leave a comment:

Working...
X