No announcement yet.

RPC over HTTP/S authentication issue

  • Filter
  • Time
  • Show
Clear All
new posts

  • RPC over HTTP/S authentication issue

    Hi Guys,

    I have been reading through the forums endlessly in relation to this problem and I have not been able to resolve it.

    Here is my setup:

    Single SBS 2003 Machine, setup to be Global Cat, DC, RPC Proxy Installed, Backend-RPC Server in System Manager.

    Here is the result from doing a rpccfg /hd on the machine:

    Server Name Port Settings
    NETBIOS 6001-6002 6004
    NETBIOS.internalfqdn 593 6001-6002 6004
    eternalfqdn 593 6001-6002 6004

    I have installed the valid certificate, created locally using the server onto the external client's machine under the trusted root folder.
    I can browse to http://externalfqdn/exchange or /rpc without any certificate pop-ups or errors.
    Ports 443, 80 and 25 have all been forwarded through to the Server

    On the Client's Outlook 2003 I have set it up with the server name as the NETBIOS name then the proxy as the eternalfqdn, Mutual Auth is unticked both slow and fast connections are ticked and basic authentication is being used.

    When I run Outlook /rpcdiag I get:
    Server Name: "NETBIOS"
    Conn: ----
    Status: Connecting

    Then it just says that the server is not contactable.

    Can anyone help me, please I have spent endless hours trying to get this running

  • #2
    Re: RPC over HTTP/S authentication issue

    My suggestion would be to go to https://servername/remote

    After you log in, click on the link on the right side labeled "Configure Outlook via the Internet"

    This will give you the correct syntax for the configuration. For example, the server should be servername.mydomain.local

    Exchange Proxy Settings should have "Only connect to proxy servers that have..." checked off and then the entry should be msstd:{}

    All this is outlined in "Configure Outlook via the Internet"
    Network Engineers do IT under the desk