No announcement yet.

My own little blackhole

  • Filter
  • Time
  • Show
Clear All
new posts

  • My own little blackhole

    Hi guys hope you can steer me in the right direction?

    I've been having troubles for a while with my exchange install i've reinstalled smtp connectors and checked policies etc but my mails seem to go into a black hole.

    I'm unable to send mails internally or out and mails that come in don't arrive. I've tried running the troubleshooting assitant but it only says "test message is sitting in one of smtp queues" (by the way i can't see it in my queues under esm -> servers -> queues, they are all empty. When i click the next step it says all queues are empty????!??!?!

    I can see google connecting but nothing else (i use gmail to test)

    Any ideas?

    Oh i forgot to say my server is and my email is [email protected]

    When I look in the message tracking center there are loads of my mails. but they all just collect there.

    Internal mails have the following lines when i double click on them:

    Report generated internally
    smtp store driver: message submitted to store
    smtp store driver submitted message to store
    unroutable report discarded

    the last message is the closet i have to a reason.

    other emails just get submitted to the MTA and then nothing.
    Last edited by elminster13; 15th June 2007, 21:19.

  • #2
    Re: My own little blackhole

    Well, it looks as if your mailserver is accepting mail OK from what I can see.

    I find it good to go into a zen like trance and imagine you are a message inside your own server.

    But that doesn't always work! But it's all we can do since we don't have hands-on on your server. Once the message is inside your machine, a task for the categorizer is to discover how it is going to route the message.

    A key place that can affect routing is the Default SMTP Virtual Server, and would affect both internal and external mail. How is that configured with you? Is the IP Address set to All Unassigned, or to the correct internal IP address?

    Another place to look at is your Connectors. To send and receive mail to\from the outside world, you should normally have created an SMTP Connector. A key tab then to fill in, if you are going to receive mail OK is the Address Space. Here you should specify your SMTP, and domain ( and a cost - say 5. Tick to allow messages to be relayed to these domains.

    If you are going to send mail out to external people correctly, then your DNS needs to be working properly. I'm assuming that you will just send mail out via your connectivity. If you are just forwarding mail to your ISP for them to forward out, then DNS is probably not so crucial to this stage, as Exchange will send any external mail out via the IP address you specified.

    Hopefully this will give you enough to go on. Let us know how you get on.



    • #3
      Re: My own little blackhole


      Thanks for your suggestions, if i were a message in my server i think i'd be pretty annoyed at not going anywhere by now!

      I checked the smtpvs and it was set to all unassigned but i only have the one nic enabled at the moment so it shouldn't have caused a problem, I changed it to the correct interface any restarted the vs but no luck.

      I do indeed have a connector in place and have assigned it * and a cost of 1 for everything.

      I have had to turn off the smtpvs as when its started a process emsmta.exe starts hogging CPU cycles, i wonder whether my mailbox store is causing some problems?

      I'm not making much progress with this, huf!


      • #4
        Re: My own little blackhole

        Well, the emsmta.exe is essentially the Exchange MTA. That doesn't normally hog CPU, so it must be busy processing messages or something! I wouldn't suspect that your mailstore has anything to do with this problem. Your mailstore is mounted and behaving normally - that is, you can at least log into your mailbox and navigate around it. And at least 'send' a message!

        I take it there aren't any significant error messages in the Application Log?

        Now MTA's can get stuck, and issues are often resolved after restarting the Exchange MTA service, but I imagine you've tried this, or even tried restarting the server.

        Now it could be that you are under some kind of 'spam attack' and this could be why your MTA is extra busy. But then, You'd expect there to be activity to indicate this in your queues and, as you say, the queues are quiet.

        Then again, I wouldn't normally expect the MTA to be busy - the MTA is really only legacy stuff now, that is used to connect back to old Exchange 5.5 servers (and any other X400 talking servers.

        So, I wonder what version of Exchange you are on? Is this your only Exchange Server? Do you have a 5.5 server lurking around? And what SP is your server on? I ask this one becasue often, problems are resolved by packing up to the latest SP. That's SP4 on Exchange 2000 and SP2 on Exchange 2003.

        Last edited by robbyb; 16th June 2007, 23:09.