Announcement

Collapse
No announcement yet.

RPC over HTTPS .. It works.. Buuut!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • RPC over HTTPS .. It works.. Buuut!

    Hello all ..

    First post here. I have been following the website though forever! excellent documentation to so many needed procedures.. great job!

    On to my odd problem, which might be simple for some..

    I have setup my rpc over https setup and have my godaddy certificate and not prompted for any permission to go further.

    Using OWA .. So my cert is fine and I just get the credentials box. I enter username and pass and I'm in.

    Outlook .. I enter the true name of the "Microsoft Exchange server" and the actual OWA address in the proxy address section. I get "the connection to the exchange server is unavailable".

    It doesnt work.. WAN side.. LAN side it works fine; it syncs up! Then when I take the laptop off the LAN and go back to the WAN connection; it works fine. I can send and receive mail. Adding a mailbox though I get "the server is offline and the mailbox cant be found".

    I'm migrating this whole movement which is currently a qmail box doing all mail work. Has been working for 4 years. I have squirrelmail setup and works fine (443).

    I would like to move to exchange for a few reasons, but here is my setup.

    OpenBSD: box on the front end; only needs port 25 open. Sends mail to the exchange server

    Exchange: same LAN and I have port 443 open to that host.

    I think this is odd because it works fine after synching on the LAN side. But then I cant add mailboxes and its like Outlook thinks its disconnected.

    Now we have this same setup at work and its great .. Our users can be anywhere and we can get them setup for their email on any machine. So I know being on the LAN initially isnt a requirement.

    I think thats about it..

    Thanks for any help you can offer ..

  • #2
    Re: RPC over HTTPS .. It works.. Buuut!

    I did much 'ing, but couldnt find anything to resemble my problem except the use of the internal FQDN for the exchange server and the external FQDN for the proxy host; which i have properly configured..

    Anyone else have an idea?

    Thanks!

    Comment


    • #3
      Re: RPC over HTTPS .. It works.. Buuut!

      Did you check whether it was actually connecting to Exchange over HTTPS inside?
      It can appear to work inside but when you check it is connecting by TCP/IP.

      To check, hold down CTRL and right click on the Outlook icon. Choose the Connection Status. That will show you the connection method.

      What I suggest for RPC over HTTPS clients is that you configure Outlook in the usual way and confirm it works. Then ADD the RPC over HTTPS settings, without changing anything else.

      Simon.
      --
      Simon Butler
      Exchange MVP

      Blog: http://blog.sembee.co.uk/
      More Exchange Content: http://exchange.sembee.info/
      Exchange Resources List: http://exbpa.com/
      In the UK? Hire me: http://www.sembee.co.uk/

      Sembee is a registered trademark, used here with permission.

      Comment


      • #4
        Re: RPC over HTTPS .. It works.. Buuut!

        This is WAN side.. its using HTTPS, but why so many connections and disconnects?
        Attached Files

        Comment


        • #5
          Re: RPC over HTTPS .. It works.. Buuut!

          Regarding this page

          I tested using the second procedure and I passed both the option 1 & 2 testing ..

          What else is there?

          Comment


          • #6
            Re: RPC over HTTPS .. It works.. Buuut!

            Just a shot, but did you try changing to basic authentication see below.
            Also when it does prompt for user ID and password use domain\user That drove me crazy for a bit.

            EDIT- I just noticed that the above article mentions the domain\user part, next time I will RTFM, oh well.
            Attached Files
            "...if I turn out to be particularly clear, you've probably misunderstood what I've said” - Alan Greenspan

            Comment


            • #7
              Re: RPC over HTTPS .. It works.. Buuut!

              Originally posted by Lior_S View Post
              Just a shot, but did you try changing to basic authentication see below.
              Also when it does prompt for user ID and password use domain\user That drove me crazy for a bit.

              EDIT- I just noticed that the above article mentions the domain\user part, next time I will RTFM, oh well.
              Hey its ok .. I cant make sense of any of this . I have even swapped out a router thingking that maybe traffic isnt being passed appropriately .. I cant get activesync to work on the mobile device either.. I get the error stating that the server certificate is invalid.. Not sure if that just a generic error that doesnt know how to present the true problem ..

              Comment


              • #8
                Fixed it finally!

                Fixed!

                Because of the "Notes" about making registry changes, I didnt change anything other than what the patcher performed ..

                Seems after making the registry changes and rebooting.. It all started working .. Mind you , I used the registry patcher form the petri install, so the 2nd portion of the registry changes I already had.

                The fix really seemed to be this part:
                HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\NTDS\Parameters

                On the Edit menu, point to New, and then click Multi-String Value.

                Note Make sure that you select the correct value type for the registry subkey. If the registry subkey type is set to anything other than Multi-String Value, you may experience problems.

                3.

                Name the new registry value NSPI interface protocol sequences.
                4.

                Right-click NSPI interface protocol sequences, and then click Modify.
                5.

                In the Value data box, type

                ncacn_http:6004
                I say that cause I had every other restry change. Also as it reads:
                If you did not install Exchange Server 2003 SP1, or if you did not configure the RPC over HTTP/S option from the GUI, then you MUST manually perform the changes in the Registry.
                Which I did ..

                but whatever..

                Thanks everyone..

                Comment


                • #9
                  Re: RPC over HTTPS .. It works.. Buuut!

                  Now .. Moving forward to my PPC-6700 from Sprint .. I cant get this to sync!

                  I have read every google topic and have tried every damn cert and pfk, cert, crt, 7pd and whatever other else file type there is to try and get this to work.

                  I'm using a cert right from the server and I'm getting the dreaded 80072f0d error ..

                  When I visit the OWA site, I get prompted to accept the certificate. I cant figure out why if I already imported it. It wont go into ROOT, it will only go into the personal section ..

                  I even imported the pfx using the import tool and it wouldnt work ..

                  Is there anything else I should be doing to get this going?

                  Thanks ..

                  EDIT: http://www.pocketpcfaq.com/faqs/acti...nge_errors.php

                  Fixed it all! I had 2 errors.. this page fixed em ..


                  LBS
                  Last edited by LBSources; 26th May 2007, 06:46.

                  Comment

                  Working...
                  X