Announcement

Collapse
No announcement yet.

Please correct your exchange server password on exchange activesync

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Please correct your exchange server password on exchange activesync

    I have battled with this for days and am growing tired from it so any help is really appreciated. Here's what has happened:

    Had a single SBS2003 server with exchange on it happily allowing active sync from win mobile 5. That crashed this week, and had to rebuild. I set up the same mailboxes and got new cert from godaddy, with the trusted root cert and installed. I have my default IIS site with a host header that is visible to the outside world. This is the domain that has the cert. I seem to connect OK with Active sync, but always seem to get the mesaage 'please correct your exchange server password' on syncing which causes failure.

    I can access OWA from the LAN and also outside on the mobile
    Cannot get to OMA on the Lan or mobile (get the following message: A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator. After a query on my username and password)

    Looking at IIS, I can see that all sites use authenticated user with SSL, and I can access some sites on IIS with my credentials from the LAN and mobile.

    Any help really appreciated.

  • #2
    Re: Please correct your exchange server password on exchange activesync

    Try the next:
    http://support.microsoft.com/kb/817379

    And on Petri's site:
    http://www.petri.com/g_search.htm?do...RID%3A11&hl=en
    CNE 5, CCA, MCSE NT4.0-2003, MCSE 2003 messaging, Exchange Server MVP.
    Tzahi Kolber - IT Supervisor
    Polycom Israel.

    Comment


    • #3
      Re: Please correct your exchange server password on exchange activesync

      I find that 817379 doesn't always work as it fails to tell you to do some additional steps before you make the registry change.

      I have written my own article that goes in to those additional steps which hasn't failed for me to date.
      http://www.amset.info/exchange/mobile-85010014.asp

      The problem is the use of require SSL. That stops EAS from working if it is set in the wrong place.

      Simon.
      --
      Simon Butler
      Exchange MVP

      Blog: http://blog.sembee.co.uk/
      More Exchange Content: http://exchange.sembee.info/
      Exchange Resources List: http://exbpa.com/
      In the UK? Hire me: http://www.sembee.co.uk/

      Sembee is a registered trademark, used here with permission.

      Comment


      • #4
        Re: Please correct your exchange server password on exchange activesync

        I've been banging away at this for days also. I have followed both articles to the letter. I ran the SBS internet wizard to reset things and made sure the virtual dir was set up right. OMA works fine but activesync just keeps on asking for the username / password and the event 529 failure audit appears in the security log (details edited to spare my customer):

        Logon Failure:
        Reason: Unknown user name or bad password
        User Name: ***
        Domain: ****.com
        Logon Type: 8
        Logon Process: Advapi
        Authentication Package: Negotiate

        The same user can access OMA with no problems. The authentication settings on OMA are the same as activesync.

        I'll work it out eventually but I've trawled and found no solution yet.
        .

        I'm going to reset my web sites (http://www.msexchange.org/tutorials/...tallation.html) and start again.
        Last edited by Symbion; 18th July 2007, 21:02. Reason: additional info

        Comment

        Working...
        X