No announcement yet.

OMA access problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • OMA access problems

    I'm having serious problems to access OMA. All other functions of exchange are working pretty good.
    I'd like to hear some experts' opinions.

    New Exchange installation: win2003 std and exchange 2003 std fully patched and updated, only exchange server in the organization (20 users) .
    The whole system seems to work fine - still in lab environment.
    The server is inside the LAN, all smtp traffic passes trough a relay server in the dmz.
    I planned to allow OMA and OWA access with https - only https (443) port opened at the firewall.

    OMA behaviour:
    1) testing with IE:
    works fine, https://myserver/oma, from inside the LAN and from the internet.
    (Since I'm using my own CA, I'm getting the "problem with certificate" warning)
    http is working fine as well from the LAN.

    2) from a cellular phone:
    "no access to the server" error.

    3) WAP emulator (from inside the LAN only)
    I have to send the domain\username - password three times, till I get the "The device you are using is not supported .... press OK". After sending the OK response, I'm asked for domain\username - password again and back to the previous step. The same for http and https.

    Previously, I've set forms-based authentification and ssl access for owa.
    I've applied the instructions in article "Problems in Synchronizing a Pocket PC with Exchange Server 2003 when using SSL and Forms-Based Authentication in OWA" (adding a virtual directory method).
    Since then, I've removed the forms-base auth. and ssl request to see if this helps, but I'm still stucked.

    I'm pretty sure that it's not a dns issue - all other functios work OK.
    I've suspected of a certificate issue, but the wap emulator is not working using http.

    Any idea what else to check, or how to bring IIS back to its default configuration to start from scratch?


  • #2
    Re: OMA access problems

    Resetting the virtual folders is the first thing I would do.

    When resetting the folders, make sure that you remember to remove the registry entry made during 817379.

    Then if you are going to following 817379 then you should do so before you put the certificate on.
    I wrote my own variant of the article here to include the steps of removing SSL and FBA before doing 817379.

    The certificate will cause a problem with handheld devices because it isn't trusted. You also need to be sure that require SSL isn't enabled on /exchange, /oma and /Microsoft-Server-ActiveSync, and if you have followed the 817379 article, the /exchange-oma folder.

    Simon Butler
    Exchange MVP

    More Exchange Content:
    Exchange Resources List:
    In the UK? Hire me:

    Sembee is a registered trademark, used here with permission.


    • #3
      Re: OMA access problems

      Thanks for the valuable tips.
      I'm working on reseting the virtual folders, and testing the whole thing again.