No announcement yet.

ActiveSync Issue

  • Filter
  • Time
  • Show
Clear All
new posts

  • ActiveSync Issue

    I am using ms exchange 2003 i am running single exchange with global catalogue my successfull test are

    OWA enable SSL
    RPC Over HTTPS

    seems everythig is working fine except OMA and Microsoft-Server-ActiveSync

    when i am trying browse locally this page http://netbios_name/OMA

    it gives me this error:

    System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator. (and a text in left top right after this message "Home")

    i followed this kb article as well but same error without SSL

    even i talk to people in microsoft as well but no hope they also link to this article, so now i am hopeless with this situation i found people also running this successfully with SSL after installing a certificate but my problem is i am not able to browse the page locally !!

    any help would be appreciated...




  • #2
    Re: ActiveSync Issue

    817379 does work, but it has a number of flaws.

    1. It doesn't mention that the setting "Require SSL" breaks OMA/EAS. You need to turn that off. Don't confuse the setting for require SSL with your ability to use SSL.
    2. It doesn't mention that you should be making that change before you setup SSL.

    Therefore, do the following.

    1. Disable the option for forms based authentication in ESM, then drop in to a command prompt and type iisreset.
    2. Remove the SSL certificate from the site.
    3. Remove the "Require SSL" from all virtual directories, run iisreset again.
    4. Delete the additional virtual directory that you created earlier and remove the connection restriction on the /exchange virtual directory that 817379 stated. Run iisreset again.
    5. Repeat what 817379 said about exporting the virtual directory to a file and moving it across to a new directory. Ensure that the directory that you use is the same one that you have set in the registry. Run iisreset again.
    7. Once the export/import has been done, set the SSL certificate back on the site, but do not set the require ssl option.

    Test and it should be working.

    If you find that it is still not working, then remove the ssl certificate again and run iisreset. Then reset the virtual directories using this article:

    Then repeat the process.

    Simon Butler
    Exchange MVP

    More Exchange Content:
    Exchange Resources List:
    In the UK? Hire me:

    Sembee is a registered trademark, used here with permission.