Announcement

Collapse
No announcement yet.

IMF Filter suddenly not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • IMF Filter suddenly not working

    I installed a NETSatisFAXtion Exchange Gateway for email. Suddenly, the IMF spam filter is not working. Iíve since then uninstalled the Exchange NS Gateway.

    Iíve checked all the exchange settings. All emails are getting through.

    Any help would be appreciated.

  • #2
    Re: IMF Filter suddenly not working

    Have you restarted the SMTP service since removing that application?
    If not, drop in to a command prompt and type

    iisreset

    and press enter

    Then restart the SMTP Service.

    Check whether IMF is enabled then.

    Simon.
    --
    Simon Butler
    Exchange MVP

    Blog: http://blog.sembee.co.uk/
    More Exchange Content: http://exchange.sembee.info/
    Exchange Resources List: http://exbpa.com/
    In the UK? Hire me: http://www.sembee.co.uk/

    Sembee is a registered trademark, used here with permission.

    Comment


    • #3
      Re: IMF Filter suddenly not working

      Originally posted by Sembee View Post
      Have you restarted the SMTP service since removing that application?
      If not, drop in to a command prompt and type

      iisreset

      and press enter

      Then restart the SMTP Service.

      Check whether IMF is enabled then.

      Simon.
      Inbound messages are not being filtered by Exchangeís Intelligent Message Filter (IMF).
      I followed these instructions:
      Configuring Exchange for Use With the SMTP Gateway
      http://notes.faxback.com/knowledgeba...6?OpenDocument

      Which of the following instruction numbers would have affected the IMF?

      I tried resetting iisreset, but nothing. I went into the Exchange System Manager and I stopped the Default SMTP Virtual Server and then started it back up again. I did not go into Services and re-started Simple Mail Transfer Protocol (SMTP), because it would freeze and I would have to re-boot the server.

      You mentioned to check whether IMF is enabled. How do I check if IMF is enabled?

      How do really re-start the complete exchange server without re-booting the PC?

      Thanks

      Comment


      • #4
        Re: IMF Filter suddenly not working

        The instructions for an IP address immediately look suspicious and would be the first thing I would remove.

        Simon.
        --
        Simon Butler
        Exchange MVP

        Blog: http://blog.sembee.co.uk/
        More Exchange Content: http://exchange.sembee.info/
        Exchange Resources List: http://exbpa.com/
        In the UK? Hire me: http://www.sembee.co.uk/

        Sembee is a registered trademark, used here with permission.

        Comment


        • #5
          Re: IMF Filter suddenly not working

          Originally posted by Sembee View Post
          The instructions for an IP address immediately look suspicious and would be the first thing I would remove.

          Simon.
          In which step?

          I removed everything in the following instructions:
          Configuring Exchange for Use With the SMTP Gateway
          http://notes.faxback.com/knowledgeba...6?OpenDocument

          You mentioned to check whether IMF is enabled. How do I check if IMF is enabled? Iíve check for the IMF through Mail Delivery and the Default SMTP Virtual Server. I made sure it was enabled. Is there another method to check?

          How do I re-start the exchange server without re-booting the PC? Which services do I need to re-start?

          Also I made another discovery, see the attachment.
          Upon checking the Exchange QUEUE, I see something about Connector for NET SatisFAXtion how do I remove this?

          I know I have three questions. Itís a lot. But I need to get IMF working again. All emails are getting through including thousands of spam.

          Any help would be appreciated.
          Thanks
          Attached Files

          Comment


          • #6
            Re: IMF Filter suddenly not working

            There is only one place where IMF is enabled - and that is on the SMTP virtual server.
            The connector you have mentioned can only be with the other Connectors in Connectors, or Routing Groups, Connectors (depending on your view).

            While you can restart the Exchange services, in this particular case I would recommend a reboot of the Exchange server. You are going to disrupt the users anyway, so you may as well do it once and get it over with.

            Simon.
            --
            Simon Butler
            Exchange MVP

            Blog: http://blog.sembee.co.uk/
            More Exchange Content: http://exchange.sembee.info/
            Exchange Resources List: http://exbpa.com/
            In the UK? Hire me: http://www.sembee.co.uk/

            Sembee is a registered trademark, used here with permission.

            Comment


            • #7
              Re: IMF Filter suddenly not working

              Originally posted by Sembee View Post
              There is only one place where IMF is enabled - and that is on the SMTP virtual server.
              The connector you have mentioned can only be with the other Connectors in Connectors, or Routing Groups, Connectors (depending on your view).

              While you can restart the Exchange services, in this particular case I would recommend a reboot of the Exchange server. You are going to disrupt the users anyway, so you may as well do it once and get it over with.

              Simon.
              I got rid of the NET SatisFAXtion connector. The only connector I have is Internet Mail SMTP Connector (GBSERVER5). I got my exchange server the original way before the Net SatisFAXtion install. Except, of the attachment.

              I see something about Connector for NET SatisFAXtion how do I remove this from the exchange QUEUE?
              Attached Files

              Comment


              • #8
                Re: IMF Filter suddenly not working

                That queue item will disappear over time.
                Are there any objects in that queue? If so, delete them and then the object will go.

                Simon.
                --
                Simon Butler
                Exchange MVP

                Blog: http://blog.sembee.co.uk/
                More Exchange Content: http://exchange.sembee.info/
                Exchange Resources List: http://exbpa.com/
                In the UK? Hire me: http://www.sembee.co.uk/

                Sembee is a registered trademark, used here with permission.

                Comment


                • #9
                  I got Exchange IMF filter to WORK!

                  I got Exchange IMF filter to Work!
                  I ran Microsoft Updates and it did the following Updates:
                  - Intelligent Message Filter for Exchange Server 2003: 2006.11.30 (KB907747)
                  - Exchange Server 2003 Service Pack 2 (KB924334) - Non-cluster
                  - Security Update for Exchange Server 2003 Service Pack 2 (KB912442) - Non-cluster

                  Then I ran the following:
                  - The iisreset from the command prompt.
                  -
                  I did not run Windows Updates but I ran Microsoft Updates
                  http://update.microsoft.com/microsof...6/default.aspx
                  What Is Microsoft Update?
                  It's the new website from Microsoft that helps you update Microsoft Windows and many other Microsoft programs that you've installed, such as Microsoft Office, Microsoft Exchange Server and Microsoft SQL Server, all in one convenient place.

                  I hope this helps someone else.

                  Comment


                  • #10
                    Re: Thanks for sharing

                    Thanks for sharing your answer with us! I'm sure others will also benefit from knowing what was wrong and how you fixed it.

                    Cheers,

                    Daniel Petri
                    Microsoft Most Valuable Professional - Active Directory Directory Services
                    MCSA/E, MCTS, MCITP, MCT

                    Comment

                    Working...
                    X