Announcement

Collapse
No announcement yet.

Restricting users from sending and receiving Internet Email?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Restricting users from sending and receiving Internet Email?

    How do I Restrict some users from sending and receiving Internet Email?

    Iíve tried this, it didnít work. http://support.microsoft.com/kb/924635
    Iíve also tried this, it didnít work. http://www.msexchange.org/tutorials/MF009.html
    I log in as the user, then I send an internet email, the email are still gets through to my test yahoo.com account.

    Am I missing something in the instructions? I like the msexchange way of doing it, but emails still get through to the internet.

    1) Under the Active Directory I created an Email Restriction Group.
    2) I added in the users to restrict.
    3) In Exchange System Manager I created a new Connector along with the defaulted Internet Mail SMTP Connector (GBSERVER5) I added Default SMTP Connector.
    4) In the Default SMTP Connector I added the Email Restriction Group in the Delivery Restrictions tab.
    5) Added the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\RESvc\Parameters\
    Value Name: CheckConnectorRestrictions
    Data Type: REG_DWORD
    Radix: Hexadecimal
    Value: 1
    6) Thatís it.
    After doing this emails are still getting through to the internet

    Iím running the following:
    Windows 2003 Server R2
    Exchange 2003 Server SP2

    Any help would be appreciated.

  • #2
    Re: Restricting users from sending and receiving Internet Email?

    I think the solution to your problem is very simple:

    You didn't need to create additional SMTP connector.

    You actually added the restricted group to the new connector - but the users can use the other SMTP connector in order to send & receive emails !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    You can use only the default SMTP connector and add the restricted group in the connector under the "Restrict message from"

    * Follow the Msexchange.org article - it is the easiest way.

    CNE 5, CCA, MCSE NT4.0-2003, MCSE 2003 messaging, Exchange Server MVP.
    Tzahi Kolber - IT Supervisor
    Polycom Israel.

    Comment


    • #3
      Re: Restricting users from sending and receiving Internet Email?

      Still NOT workingÖ

      1) Under the Active Directory I created a new group No Internet Mail Group. It's a Mail-Enable Universal-Distribution group. Email address is [email protected]l.
      2) I added in the users to restrict in the No Internet Mail group.
      3) In Exchange System Manager I added the No Internet Mailgroup to the defaulted Internet Mail SMTP Connector (GBSERVER5). There's only one connector.

      What I really want to accomplish is restricting users from sending outside emails.

      I donít want specific users to send outside emails.
      Attached Files

      Comment


      • #4
        Re: Restricting users from sending and receiving Internet Email?

        Did you check the next link in the Msexchange.org in the same article?

        2. Add the users who will not have the ability to send Internet based mail into this group.
        IMPORTANT: If you are going to use a group for the restrictions you must also edit the Registry to enable this feature, look at http://support.microsoft.com/default...;en-us;Q277872 for the necessary Registry changes you must make.


        http://support.microsoft.com/default...;en-us;Q277872
        CNE 5, CCA, MCSE NT4.0-2003, MCSE 2003 messaging, Exchange Server MVP.
        Tzahi Kolber - IT Supervisor
        Polycom Israel.

        Comment


        • #5
          Re: Restricting users from sending and receiving Internet Email?

          I have done this. I my first post, step number 5.

          Did I do this correctly? I believe I have.
          Attached Files

          Comment


          • #6
            Re: Restricting users from sending and receiving Internet Email?

            Did you restart the SMTP in order that changes will take effect?

            5. Restart the Microsoft Exchange Routing Engine service and the Simple Mail Transfer Protocol (SMTP) services for this change to take effect.
            CNE 5, CCA, MCSE NT4.0-2003, MCSE 2003 messaging, Exchange Server MVP.
            Tzahi Kolber - IT Supervisor
            Polycom Israel.

            Comment


            • #7
              Re: Restricting users from sending and receiving Internet Email?

              IT WORKED!!!

              I did not do the following:
              5. Restart the Microsoft Exchange Routing Engine service and the Simple Mail Transfer Protocol (SMTP) services for this change to take effect.

              YOU'RE RIGHT!!!

              THANK YOU

              From the test user:
              Your message did not reach some or all of the intended recipients.

              Subject: test email 29
              Sent: 12/1/2006 12:55 PM

              The following recipient(s) could not be reached:

              '[email protected]' on 12/1/2006 12:55 PM
              You do not have permission to send to this recipient. For assistance, contact your system administrator.
              <smtp.great.com #5.7.1>

              Comment


              • #8
                Re: Thanks for sharing

                Thanks for sharing your answer with us! I'm sure others will also benefit from knowing what was wrong and how you fixed it.



                However, we'de appreciate it if you could grant some reputation points to the user that helped you. Just click on the little Yin-Yang icon on the right of the user's answer and follow the prompt.
                Cheers,

                Daniel Petri
                Microsoft Most Valuable Professional - Active Directory Directory Services
                MCSA/E, MCTS, MCITP, MCT

                Comment


                • #9
                  Re: Restricting users from sending and receiving Internet Email?

                  Thank you all for the compliments
                  CNE 5, CCA, MCSE NT4.0-2003, MCSE 2003 messaging, Exchange Server MVP.
                  Tzahi Kolber - IT Supervisor
                  Polycom Israel.

                  Comment

                  Working...
                  X