Announcement

Collapse
No announcement yet.

Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

    Hi,

    I'm using a Windows 2003 Server, with Exchange 2003.
    The goal is: Sending mail with exchange with local ISP.

    My error notice:

    ATT00384.TXT
    Code:
    Reporting-MTA: dns;edison
    
    Final-Recipient: rfc822;[email protected]
    Action: delayed
    Status: 4.4.7
    Will-Retry-Until: Sun, 17 Sep 2006 01:13:15 +0200
    X-Display-Name: [email protected]
    Result of SmtpDiag:
    Code:
    Searching for Exchange external DNS settings.
    Computer name is EDISON.
    VSI 1 has the following external DNS servers:
    There are no external DNS servers configured.
    
    Checking SOA for gmail.com.
    Checking external DNS servers.
    Checking internal DNS servers.
    SOA serial number match: Passed.
    
    Checking local domain records.
    Checking MX records using TCP: busser.int.
    Checking MX records using UDP: busser.int.
    Both TCP and UDP queries succeeded. Local DNS test passed.
    
    Checking remote domain records.
    Checking MX records using TCP: gmail.com.
    Checking MX records using UDP: gmail.com.
    Both TCP and UDP queries succeeded. Remote DNS test passed.
    
    Checking MX servers listed for [email protected]
    Connecting to gmail-smtp-in.l.google.com [72.14.215.27] on port 25.
    Connecting to the server failed. Error: 10060
    Failed to submit mail to gmail-smtp-in.l.google.com.
    Connecting to gmail-smtp-in.l.google.com [72.14.215.114] on port 25.
    Connecting to the server failed. Error: 10060
    Failed to submit mail to gmail-smtp-in.l.google.com.
    Connecting to alt2.gmail-smtp-in.l.google.com [64.233.185.27] on port 25.
    Connecting to the server failed. Error: 10060
    Failed to submit mail to alt2.gmail-smtp-in.l.google.com.
    Connecting to alt1.gmail-smtp-in.l.google.com [64.233.163.27] on port 25.
    Connecting to the server failed. Error: 10060
    Failed to submit mail to alt1.gmail-smtp-in.l.google.com.
    Connecting to alt2.gmail-smtp-in.l.google.com [64.233.185.114] on port 25.
    Connecting to the server failed. Error: 10060
    Failed to submit mail to alt2.gmail-smtp-in.l.google.com.
    Connecting to alt1.gmail-smtp-in.l.google.com [64.233.163.114] on port 25.
    Connecting to the server failed. Error: 10060
    Failed to submit mail to alt1.gmail-smtp-in.l.google.com.
    Connecting to gsmtp183.google.com [64.233.183.27] on port 25.
    Connecting to the server failed. Error: 10060
    Failed to submit mail to gsmtp183.google.com.
    Connecting to gsmtp163.google.com [64.233.163.27] on port 25.
    Connecting to the server failed. Error: 10060
    Failed to submit mail to gsmtp163.google.com.
    Any ideas what would causing this?
    I've searched the net days, unfortunatly without luck.

    Thx,
    Jimmy

  • #2
    Re: Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

    Sending mail with exchange with local ISP.
    Do you mean that the local ISP handles the mail, or that the ISP only provides connectivity?
    "...if I turn out to be particularly clear, you've probably misunderstood what I've said” - Alan Greenspan

    Comment


    • #3
      Re: Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

      Originally posted by Lior_S
      Do you mean that the local ISP handles the mail, or that the ISP only provides connectivity?
      ISP handles the mail,
      SMTP connector configured confirm all manuals that I found:
      Forward to SMTP from ISP
      Adress Space: *
      Outbound Security: Basic authentification with ISP username and password

      Comment


      • #4
        Re: Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

        The log shows that the smtp tries to connect directly to the smtp servers of gmail but cannot establish a connection at tcp 25 port. Is there something blocking 25/tcp outside?

        Comment


        • #5
          Re: Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

          Yes ISP blocks that, my ISP doesn't allow relaying!

          I tought it should work like this:
          • the SMTP connector connects with my ISP (smtp.telenet .be) with my creditials.
          • Then the ISP delivers the mail to gmail, and in this case i should get rejection for sending to a unkown email adress

          Comment


          • #6
            Re: Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

            What you need to do is add a smarthost to your ISP.

            Open ESM.
            Open Admin Groups.
            Open Your Site.
            Open Routing Groups.
            Open Your Site.
            Open Connectors.
            Right Click on your SMTP connector and select properties.
            On the first page you will have an option to Froward All Mail Through this connector to the following SmartHosts.
            Enter your ISP's server in there.
            Click on the Advanced Tab.
            Click on outbound security and then choose the security required for your UN an PWD.

            Hopefully this should work.

            Comment


            • #7
              Re: Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

              Hi wullieb1,

              If I understand you correctly, then this is exactly what i did:

              Originally posted by HomeBunny
              ISP handles the mail,
              SMTP connector configured confirm all manuals that I found:
              Forward to SMTP from ISP
              Adress Space: *
              Outbound Security: Basic authentification with ISP username and password
              More ideas? Can I test somthing else?

              Comment


              • #8
                Re: Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

                If you have that set then there must be something realy wrong with your server as it is trying to connect directly to the server that handles the mail for gmail.

                I'm presuming that the same happens with other email addresses??

                Comment


                • #9
                  Re: Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

                  Is this the same as part as the one you have edited??
                  Attached Files

                  Comment


                  • #10
                    Re: Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

                    Make sure that you haven't set a smart host directly on the SMTP virtual server. If you have that overrides anything else that you may do - including SMTP Connectors.

                    ESM, Servers, <your server>, Protocols, SMTP. Right click on the SMTP VS and choose Properties. Click on the tab "Delivery" and then Advanced. Ensure that SmartHost is blank.

                    Does the ISP require authentication when you send an email through their server. Not all ISPs do. Others have restrictions on what can be sent through their server until you speak to them.

                    Simon.
                    --
                    Simon Butler
                    Exchange MVP

                    Blog: http://blog.sembee.co.uk/
                    More Exchange Content: http://exchange.sembee.info/
                    Exchange Resources List: http://exbpa.com/
                    In the UK? Hire me: http://www.sembee.co.uk/

                    Sembee is a registered trademark, used here with permission.

                    Comment


                    • #11
                      Re: Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

                      I think I've done allright, see screenshots

                      Sembee, The ISP needs authentication.
                      wullieb1, This indeed happens with all email addresses.
                      Attached Files

                      Comment


                      • #12
                        Re: Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

                        I know this may be way off but your FQDN isn't fully resolved on the first screen you posted.

                        Comment


                        • #13
                          Re: Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

                          Originally posted by wullieb1
                          I know this may be way off but your FQDN isn't fully resolved on the first screen you posted.
                          Indeed, update this with FQDN, rebooted server. Still no luck here

                          Someone any other idea? Would reinstalling helping?

                          Comment


                          • #14
                            Re: Action: delayed, Status: 4.4.7, When sending to a mailbox outside my local domain

                            This may or may not be it, but -

                            I have a client who was unable to send email from the Exchange Server inside the local domain via his ISP smart host. The host was Bellsouth. He could send just fine by allowing the Exchange server to send mail directly to the recipients, but was blocked by more and more mail servers that do not accept smtp connections from IP addresses identified as a DSL or Dynamic IP connection. His was a static IP, but on a DSL connection.

                            No matter what I tried, the Bellsouth outgoing server would accept outgoing mail from a workstation, but not from the mail server. I tried it with authentication and without. There was no real solution till the client dumped Bellsouth and got a T1 line. There was a workaround that I used, however.

                            Now that they have a T1 line I still have them sending outgoing email via a smart host provided by the new ISP even though they would probably not suffer the "blocked IP" problem as described above. I could not get it to work through Bellsouth, but have no problem with the new ISP.

                            The workaround: The client had contracted with a web hosting company for web site design and hosting. They also provide email services for those customers do not use their own mail servers. While the client was still stuck with Bellsouth I asked the Web Site host if we could use THEIR outgoing SMTP server to send mail. They agreed.

                            In Exchange, instead of entering Bellsouth's SMTP smart host I entered the SMTP server of the web hosting company.

                            The bottom line was, Bellsouth SMTP servers were just plain NOT configured to allow another server to relay mail through them and because they are the great big elephant it was impossible to get them to change their settings. If you have it all configured perfectly, your ISP might still be the problem and either doesn't understand the problem they are causing you, or they are unwilling to change their settings for your benefit.

                            So, if there is anyone who would let you connect to their SMTP server to relay email who does NOT have a problem sending email, you might get them to let you use their server as a relay. If this is the problem, then the other solution is to change ISPs.

                            If you have another mail server someplace that you could use as a relay to test, this would let you narrow the problem down. Since I have multiple clients, I do this at times and there are ways to make sure that ONLY your problem server can connect to the relay server. You don't want to create an Open Relay Server for even a short period of time.

                            Comment

                            Working...
                            X