Announcement

Collapse
No announcement yet.

mmc could not create snap-in

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • mmc could not create snap-in

    Hello, my new laptop came with Vista Home Premium SP1 (preloaded), it has problem with the Event Viewer. Each time when I open the Event Viewer it comes up with the message "MMC could not create snap-in". Does anyone know how to fix this problem.

  • #2
    Re: mmc could not create snap-in

    I would initially speak to the company you bought it from as it may be a known issue to them and they may have a fix.
    Secondly I would try creating a new profile and seeing if it happens there too, try it as an admin and also standard user.
    Check windows update as well.

    Seems this is similar too.
    http://forums.techarena.in/vista-adm...ion/919249.htm
    cheers
    Andy

    Please read this before you post:


    Quis custodiet ipsos custodes?

    Comment


    • #3
      Re: mmc could not create snap-in

      Thanks for the help. I've tried two of your suggestions so far. I'm waiting for a reply to my email from the support centre of the company I got the laptop from, hopefully they can help. I also tried new profiles but had the same problem. I'll go back to Microsoft and see if I can find some sort of answer. I'll keep you posted.

      I've now tried all possibilities suggested and unfortunately none of them worked. The help centre said quote, "This is unfortunately a Windows Vista Issue" and they sent me to Microsoft support page which is for a similar problem, it was for Windows Server 2003 (which I don't have) but I tried the fix anyway and it didn't work, (no surprise). Microsoft wanted to charge me to get some help because Vista SP1 came preinstalled, and I couldn't find any downloads or updates on their site that could help me.

      PROBLEM SOLVED: Turns out it was missing registry entry or entries that caused the problems I was having. After a full factory reset and then through a process of elimination we discovered it was "RegScrubVista" that was to blame. It scrubbed a bit too much from the registry. I now use a different registry cleaning program and no problems. Thank you to everyone who thought about this problem for me.
      Last edited by BecK; 7th October 2008, 00:54. Reason: further information

      Comment

      Working...
      X