No announcement yet.

Vista SP1: Administrative Tools CPL missing, how do I restore it?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Vista SP1: Administrative Tools CPL missing, how do I restore it?

    OS: Vista Home Premium SP1

    After upgrading to SP1 via software update, the Administrative Tools Control Panel Applet is missing - when I click on Control Panel > System > Administrative Tools or enter "control admintools", an empty folder opens. Following this thread, I navigated to

    C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools

    which is indeed empty with the exception of a desktop.ini with the following contents:

    Respondent Ramesh advises to place the links back in there along with a different desktop.ini file:

    Memory Diagnostics Tool.lnk=@%SystemRoot%\system32\MdSched.exe,-4001
    System Configuration.lnk=@%systemroot%\system32\msconfig.exe,-126
    Reliability and Performance Monitor.lnk=@%SystemRoot%\system32\wdc.dll,-10021
    Data Sources (ODBC).lnk=@%SystemRoot%\system32\odbcint.dll,-1310
    Windows Firewall with Advanced Security.lnk=@%SystemRoot%\System32\AuthFWGP.dll,-20
    Computer Management.lnk=@%SystemRoot%\system32\mycomput.dll,-300
    iSCSI Initiator.lnk=@%SystemRoot%\system32\iscsicpl.dll,-5001
    Event Viewer.lnk=@%SystemRoot%\system32\miguiresource.dll,-101
    Task Scheduler.lnk=@%SystemRoot%\system32\miguiresource.dll,-201
    Print Management.lnk=@%systemroot%\system32\pmcsnap.dll,-700
    Security Configuration Management.lnk=@%SystemRoot%\system32\wsecedit.dll,-718
    Unfortunately, this only restores the links themselves but not the Control Panel Applet.

    How do I restore the Control Panel Applet?

    EDIT: Perhaps I wasn't clear enough so let me put it this way:

    The Control Panels and subpanels are basically folders with links pointing here and there. If I understand correctly, the control panel applets "style" the explorer window so that it looks like a control panel, not just another explorer window.

    The step above restores the links to their place but the "Administrative Tools" control panel itself doesn't show - it shows like a normal explorer folder view. How do I restore the control panel "styling"to the folder?
    Last edited by archis; 22nd March 2008, 13:36.