No announcement yet.

Windows 8 and gpo scripts

  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 8 and gpo scripts

    I have a script to silently install an .exe program (Sadly no .msi is available) on startup. This script works fine via group policy for Windows XP, Vista and Windows 7 machines but does not work on any windows 8 machines. I receive no errors when viewing gpresult and rsop and they say success. To troubleshoot I have the script running at startup and shutdown, have rebooted multiple times, completely shutdown as well all with the same results. I have copied the files and ran the script locally on my windows 8 machine from an administrator account and it still does not work. User Account Control (UAC) is turned off. The only way it executes properly is if I run as administrator and run it. Is there any work around through group policy to get these windows 8 machines to run the script properly?
    I have also tried via powershell and receive the same results (only works if I run as administrator). I have a second powershell command to add an active directory user to the local administrators group and that works fine so I know that Startup powershell scripts do work via group policy on my windows 8 machines. Is there some GPO setting that I can tweak either locally or globally to allow scripts to run? Has anyone else ran into this issue?

  • #2
    Re: Windows 8 and gpo scripts

    Maybe try this (only a guess I'm afraid)

    Please read this before you post:

    Quis custodiet ipsos custodes?