Announcement

Collapse
No announcement yet.

Can't get MDT imaging to work

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get MDT imaging to work

    Not sure where to put this so I'm sticking it in here since the OS's involved are all Windows 7. Obviously feel free to move this if it belongs elsewhere. Thanks.

    This is driving me crazy. I'm hoping someone here can help me out. Here's the current configuration:

    Windows 7 PC
    4 GB RAM
    MDT 2012
    Windows AIK
    Windows ADK for 8.1

    I've created a vm for the reference image and have the .wim file ready to go. The task has been created and I can boot to the deployment screen. I make all my selections and the installation works fine. Once it does it's first reboot, however, after a few minutes of finding and installing devices it errors out.

    The first error is "Windows could not parse or process unattend answer file [C:\windows\Panther\unattend.xml] for pass [specialize]. A component or setting specified in the answer file does not exist."

    I click OK on the window that popped up and the computer reboots, then I get another window that says "The computer restarted unexpectedly or encountered an unexpected error. windows installation cannot proceed. To install Windows, click "OK" to restart the computer, and then restart the installation."

    I've looked through the unattend.xml and I can't see where it's getting hung up. I looked in the logs and can't see it there, either.

    Help?

  • #2
    Re: Can't get MDT imaging to work

    it will be fixed by making a simple change to the unattend.xml file associated with your deployment task sequence:

    Navigate to your unattend.xml file in the deployment share, in my case it is C:\DeploymentShare\Control\WIN7-IE10\unattend.xml, right-click the unattend.xml and choose edit. This should open the unattend.xml file in Notepad.

    Find the line <IEWelcomeMsg>false</IEWelcomeMsg> from within the unattend.xml (you could also do a search by going to Edit => Find from the Notepad menu).

    Once you find it, you can either remove the line completely or comment it out by changing it to <!–<IEWelcomeMsg>false</IEWelcomeMsg> –>

    Once you make the change, save the unattend.xml file and restart your deployment. Everything should be back to normal again

    REF: http://windowsdeployments.net/mdt-er...s-7-with-ie10/
    MOD: TehCamel has added a reference for the source of this data.
    Last edited by tehcamel; 14th February 2014, 08:59. Reason: Added a reference.

    Comment


    • #3
      Re: Can't get MDT imaging to work

      Originally posted by VMware View Post
      it will be fixed by making a simple change to the unattend.xml file associated with your deployment task sequence:

      Navigate to your unattend.xml file in the deployment share, in my case it is C:\DeploymentShare\Control\WIN7-IE10\unattend.xml, right-click the unattend.xml and choose edit. This should open the unattend.xml file in Notepad.

      Find the line <IEWelcomeMsg>false</IEWelcomeMsg> from within the unattend.xml (you could also do a search by going to Edit => Find from the Notepad menu).

      Once you find it, you can either remove the line completely or comment it out by changing it to <!–<IEWelcomeMsg>false</IEWelcomeMsg> –>

      Once you make the change, save the unattend.xml file and restart your deployment. Everything should be back to normal again
      VMware, I will give that a try and pray you're right...

      I'll keep you posted.

      Comment


      • #4
        Re: Can't get MDT imaging to work

        Originally posted by VMware View Post
        it will be fixed by making a simple change to the unattend.xml file associated with your deployment task sequence:

        Navigate to your unattend.xml file in the deployment share, in my case it is C:\DeploymentShare\Control\WIN7-IE10\unattend.xml, right-click the unattend.xml and choose edit. This should open the unattend.xml file in Notepad.

        Find the line <IEWelcomeMsg>false</IEWelcomeMsg> from within the unattend.xml (you could also do a search by going to Edit => Find from the Notepad menu).

        Once you find it, you can either remove the line completely or comment it out by changing it to <!–<IEWelcomeMsg>false</IEWelcomeMsg> –>

        Once you make the change, save the unattend.xml file and restart your deployment. Everything should be back to normal again
        Darn VMware, that didn't work. It actually says "Incorrect syntax was used in a comment. <!-IEWelcomeMSG>false</IEWelcomeMsg> ->

        Any other ideas?

        Comment


        • #5
          Re: Can't get MDT imaging to work

          If that's a copy and paste, you're missing a bracket before the first I.

          From VMware:..<!–<IEWelcomeMsg>false</IEWelcomeMsg> –>
          From you:........<!-IEWelcomeMSG>false</IEWelcomeMsg> ->
          Last edited by Bertmax; 10th February 2014, 18:14.

          Comment


          • #6
            Re: Can't get MDT imaging to work

            Originally posted by Bertmax View Post
            If that's a copy and paste, you're missing a bracket before the first I.

            From VMware:..<!–<IEWelcomeMsg>false</IEWelcomeMsg> –>
            From you:........<!-IEWelcomeMSG>false</IEWelcomeMsg> ->
            Nah, it's not a copy/paste. I just mistyped in here. I've triple checked it and the syntax is correct in the unattend file...

            Comment


            • #7
              Re: Can't get MDT imaging to work

              Here is a guide looking at it MDT will do the unattend file and sysprep it for you if you follow it.
              https://blogs.technet.com/b/askcore/...-mdt-2010.aspx
              Please remember to award reputation points if you have received good advice.
              I do tend to think 'outside the box' so others may not always share the same views.

              MCITP -W7,
              MCSA+Messaging, CCENT, ICND2 slowly getting around to.

              Comment


              • #8
                Re: Can't get MDT imaging to work

                Good found here by
                Originally posted by VMware View Post
                •Find the line <IEWelcomeMsg>false</IEWelcomeMsg> from within the unattend.xml
                The IEWelcomeMsg setting is deprecated in Internet Explorer 10 and it must be removed from the unattend.xml file.


                Originally posted by Thrasonic View Post
                The error message actually says "Incorrect syntax was used in a comment. <!-IEWelcomeMSG>false</IEWelcomeMsg> ->

                Any other ideas?
                The line exists in your unattend.xml therefore it must be removed.
                The error message you now get after commented it out, actually says that "the syntax within the comment is incorrect". You can try this,
                Code:
                <!-- <IEWelcomeMsg>false</IEWelcomeMsg> -->
                (make sure to use all 'short' dashes!) When unsuccessful, then simply remove the line.


                additional reading;
                Win7 + IE10 Slipstream error
                Deploy Windows 7 and IE10 in the same reference image

                /Rems

                This posting is provided "AS IS" with no warranties, and confers no rights.

                __________________

                ** Remember to give credit where credit's due **
                and leave Reputation Points for meaningful posts

                Comment


                • #9
                  Re: Can't get MDT imaging to work

                  Okay, I got past that problem by going into the unattend.xml file by using the GUI interface through the MDT (right-click the task sequence in MDT, left-click Properties, click the OS Info tab and click the Edit unattand.xml button).

                  In there I had to go into the specialize section, locate that IE Welcome Screen option, right-click it and select the option to revert the change (or whatever it said). Even if it says False already do this and it'll fix the issue.

                  Comment


                  • #10
                    Re: Can't get MDT imaging to work

                    Originally posted by VMware View Post
                    it will be fixed by making a simple change to the unattend.xml file associated with your deployment task sequence:

                    Navigate to your unattend.xml file in the deployment share, in my case it is C:\DeploymentShare\Control\WIN7-IE10\unattend.xml, right-click the unattend.xml and choose edit. This should open the unattend.xml file in Notepad.
                    hi VMWare, your comments are helpful and I'm sure the forum members appreciate your posts.

                    However - in future, if the source isn't yours (or even if it is and you have cross-posted it word for word elsewhere) it would be beneficial if you could provide the link.

                    thanks!
                    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

                    Comment


                    • #11
                      Re: Can't get MDT imaging to work

                      This is a good example of why unattend files should be edited with the Windows System Image Manager (SIM), which is the GUI interface used by Thrasonic. Windows SIM can also be used to validate the answer file to ensure compatibility with the deployment. Instructions on how to validate the file are available here on TechNet. Any time an issue is encountered with the answer file, validation is a good first step.

                      Brandon
                      Windows Outreach Team- IT Pro
                      The Springboard Series on TechNet

                      Comment

                      Working...
                      X