Announcement

Collapse
No announcement yet.

Unable to RDP via VPN

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to RDP via VPN

    I have a Windows 7 Pro (32-bit) workstation that is set up to allow remote access. I have RDP set to allow access to different versions of Remote Desktop and Windows Firewall is disabled. When I am within the LAN, I have no problems reaching this PC via RDP, which I've tested from various Windows OS's. However, when I am at home on my Windows 7 PC, I cannot use RDP to connect to my work workstation. I am able to reach verious servers of different Windows versions through the VPN connection, and I'm able to use the RDP client of the server to connect to the workstation, but I can't connect directly from home.

    Thoughts? Please let me know what other information I should include.

  • #2
    Re: Unable to RDP via VPN

    A suggestion here that it might be firewall / av issues:
    http://en.kioskea.net/forum/affich-5...connect-remote

    This (may need to access via a search engine) mentions VPN apps can block specific ports:#
    http://www.experts-exchange.com/Netw..._22031123.html

    Do you have control over the VPN appliance / server?
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Unable to RDP via VPN

      Well, I don't control the VPN directly, but I can get it changed. However, through the VPN, I can RDP to other computers on the network, just not this particular one, which leads me to believe the VPN isn't the problem. Now, when I am at work, on the network, I can use RDP to connect to my workstation from other computers, which tells me that it's not the AV on the computer preventing connection. Also, when I was running server 2003 on this box, running the same AV program (Kaspersky), I could connect from home. Also, I can't use the IP address of the machine any more than I can the hostname, which tells me DNS isn't the problem.

      My gut tells me that there is a setting in Windows 7 that I'm missing, but I'm open to other ideas. If my reasoning above is faulty, please let me know. I'm not too proud.

      Comment


      • #4
        Re: Unable to RDP via VPN

        OK -- I didn't see the bit about "other servers" in your first post
        Do you have another machine you can test with (from home)?
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Re: Unable to RDP via VPN

          Bertmax - I'm having the exact same problem. From within my work LAN I can RDP to my work computer which is running Windows 7 Pro 64-bit. But from my home computer (also running Win7 Pro 64-bit), after I connect via VPN I can RDP to Win2008 servers but not to my work computer.

          Have you found a solution yet?

          ...Cherie

          Comment


          • #6
            Re: Unable to RDP via VPN

            Have you checked firewall, antivirus can cause this problem, Rdp enabled or disabled.
            can you ping it by host name and ip address on vpn?

            Comment


            • #7
              Re: Unable to RDP via VPN

              I may have figured out the issue. We recently expanded our IP range, and I suspect the VPN has not been updated to pass traffic to the newly expanded range.

              As a test, I configured a static IP address on the computer I am not able to RDP to over VPN - the static address I used is part of the original range, prior to expansion. Once DNS updated, I was able to successfully connect to that computer via RDP while connected to VPN.

              I've asked our network administrator to ensure the VPN appliance is configured to allow traffic to our full IP range. As soon as I can confirm this is the issue, I'll post another reply.

              Comment


              • #8
                Re: Unable to RDP via VPN

                make sure that you can set particular Port number for both systems . As default port number of RDP is 3389.......
                Last edited by Rajsuvi; 7th November 2012, 07:14. Reason: port number change

                Comment


                • #9
                  Re: Unable to RDP via VPN

                  No need to specifically open ports, RDP works to servers so that's not the issue.

                  I have confirmed that the problem, at least with my issue, was that the VPN rules did not include the full IP range for my office. Once the network admin corrected the rule, RDP to my computer worked.

                  Comment

                  Working...
                  X