Announcement

Collapse
No announcement yet.

Could not reconnect all network drives

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Could not reconnect all network drives

    Hi,

    I have a log in script for all users on our server to map some network drives. The way I have the script written is to first delete the selected drive and then map the drive again with the correct location. I have about 15 users that use the exact same script and method of connecting the network drives, but 2 users show an error message that "could not reconnect all network drives." The difference between the users that are having issues is one has Windows 7 and the other has Server 2008 R2. Any suggestions?


    Thanks

  • #2
    Re: Could not reconnect all network drives

    I forgot to add that I use Active Directory not Group Policy.

    Comment


    • #3
      Re: Could not reconnect all network drives

      How do the problem users differ from working users?
      Can you post the script?
      If you edit it to map drives one by one, can you pinpoint the place it fails?
      Tom Jones
      MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
      PhD, MSc, FIAP, MIITT
      IT Trainer / Consultant
      Ossian Ltd
      Scotland

      ** Remember to give credit where credit is due and leave reputation points where appropriate **

      Comment


      • #4
        Re: Could not reconnect all network drives

        Here is the script:

        net use K: /delete
        net use F: /delete
        net use G: /delete

        rem \\WSBSRV1a\OFCSCAN\AUTOPCC

        net use K: "\\wsbsrv1a\shared folders\installs_a" /y
        net use F: "\\wsbsrv1a\shared folders\iti_a" /y
        net use G: "\\wsbsrv1a\shared folders\wsbfiles_a" /y

        net time \\wsbsrv1a /set /y

        The difference between the problem users are the operating systems, but I do have one user that uses Windows 7 and it works perfectly for him.

        Let me know if you need more info. Thanks!

        Comment


        • #5
          Re: Could not reconnect all network drives

          it's not simply a matter of the person who is logging on not having access to those shars ?
          Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

          Comment


          • #6
            Re: Could not reconnect all network drives

            The network drives are shared to all users in the domain, so I would not think having access is the issue.

            Comment


            • #7
              Re: Could not reconnect all network drives

              I would not think so either, but it is a very good idea to check permissions in reality match what you think they are!
              Tom Jones
              MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
              PhD, MSc, FIAP, MIITT
              IT Trainer / Consultant
              Ossian Ltd
              Scotland

              ** Remember to give credit where credit is due and leave reputation points where appropriate **

              Comment


              • #8
                Re: Could not reconnect all network drives

                I verified this right after reading your replay. Thank you for the idea, sometimes the simple things are forgotten. Any other ideas? Maybe there a service turned off that should be on or a network setting?

                It is very strange the only two users having this problem is actually a board room computer and one of our servers, so they are totally different types of workstations.

                Comment


                • #9
                  Re: Could not reconnect all network drives

                  Is this an SBS Server? Is it possible a Default SBS GPO may be causing an issue here?

                  Code:
                   net time \\wsbsrv1a /set /y
                  Not necessary if you are running XP and above. Win 95 & 98 did like this though.
                  1 1 was a racehorse.
                  2 2 was 1 2.
                  1 1 1 1 race 1 day,
                  2 2 1 1 2

                  Comment


                  • #10
                    Re: Could not reconnect all network drives

                    The server is running Windows Server 2008 R2, not Windows SBS. Also, all machines are running Windows XP or Windows 7.

                    Comment


                    • #11
                      Re: Could not reconnect all network drives

                      Originally posted by notsoIT View Post
                      The difference between the problem users are the operating systems, but I do have one user that uses Windows 7 and it works perfectly for him.
                      Is perhaps User Account Control active on the Windows 7 and 2008 server machines and not on that one Windows 7 machine?

                      Do some/any of the users working on these machines have local admin rights?


                      /Rems

                      This posting is provided "AS IS" with no warranties, and confers no rights.

                      __________________

                      ** Remember to give credit where credit's due **
                      and leave Reputation Points for meaningful posts

                      Comment


                      • #12
                        Re: Could not reconnect all network drives

                        One of them had local admin rights, but I turned them off and tried to log on again. Still has the error of "could not reconnect all network drives."

                        Comment


                        • #13
                          Re: Could not reconnect all network drives

                          Originally posted by Ossian View Post
                          How do the problem users differ from working users?
                          Can you post the script?
                          If you edit it to map drives one by one, can you pinpoint the place it fails?
                          How would I map the drives one by one? With the script or with the workstation manually?

                          Comment


                          • #14
                            Re: Could not reconnect all network drives

                            yea, you could use the script:
                            put a "pause" between every line

                            or, jus tlogon without the script, and do it manually entering each line from the script, looking for where it breaks.


                            I just realised what it could be.

                            Do you have enough CALs?
                            My old job, we had an SBS server, and it would stop mapping drives, once I pulled the script apart and put pauses in, i could see it was telling me that it was out of licences.
                            Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

                            Comment


                            • #15
                              Re: Could not reconnect all network drives

                              Where in the script do I put "pause"?

                              Comment

                              Working...
                              X