Announcement

Collapse
No announcement yet.

Samba Connection

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Samba Connection

    I have a Windows 7 Professional laptop that has a issue with connecting by name to a samba share through windows explorer. It connects just fine using IP but not the name.
    I thought it was a permission issue but I am able to get there by IP without any issues.
    Does anyone have an idea as to the problem?

  • #2
    Re: Samba Connection

    I presume you have checked you can actually ping it by name and that DNS is OK?
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Samba Connection

      Yes ping works, it is resolving the correct IP, and nslookup is also resolving the correct name to ip and the correct ip to name.

      Comment


      • #4
        Re: Samba Connection

        I believe Samba uses quite a bit of Netbios. Have you got any WINS servers setup?
        as it may speed up the netbios name registration process. Also, depending on how your samba is setup, DNS can help if netbios over tcp/ip is enabled.
        It looks like a name resolution issue, see if this helps: http://www.samba.org/samba/docs/man/...kBrowsing.html
        Caesar's cipher - 3

        ZKHQ BRX HYHQWXDOOB GHFLSKHU WKLV BRX ZLOO UHDOLVH LW ZDV D ZDVWH RI WLPH!

        SFX JNRS FC U6 MNGR

        Comment


        • #5
          Re: Samba Connection

          Originally posted by L4ndy View Post
          I believe Samba uses quite a bit of Netbios. Have you got any WINS servers setup?
          as it may speed up the netbios name registration process. Also, depending on how your samba is setup, DNS can help if netbios over tcp/ip is enabled.
          It looks like a name resolution issue, see if this helps: http://www.samba.org/samba/docs/man/...kBrowsing.html
          The error that it gives is a permission issue. If it was a name resolution problem then I shouldnt be able to ping by name(Which I can do). I have attached a screen shot of the error I get when I try to connect to the samba share through windows explorer. Also this user is the only one having the issue and its only on his system. I dont have the issue on anyother system.
          Attached Files

          Comment


          • #6
            Re: Samba Connection

            try this for username:

            SAMBASHARENAME\username

            and your samba password

            Comment


            • #7
              Re: Samba Connection

              Originally posted by georgeeye View Post
              try this for username:

              SAMBASHARENAME\username

              and your samba password

              There is no login.

              You may not understand what I am doing. I goto network neighborhood, I search for the system that has the share on it when I click on it I get the error I posted before.
              But I can try the same thing from another system and it works just fine.

              Comment


              • #8
                Re: Samba Connection

                So the connection by name works from another machine but not your one?
                But connection by IP does?

                Have you cleared any cached credentials?
                Tom Jones
                MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                PhD, MSc, FIAP, MIITT
                IT Trainer / Consultant
                Ossian Ltd
                Scotland

                ** Remember to give credit where credit is due and leave reputation points where appropriate **

                Comment


                • #9
                  Re: Samba Connection

                  Originally posted by Ossian View Post
                  So the connection by name works from another machine but not your one?
                  But connection by IP does?

                  Have you cleared any cached credentials?

                  cached credentials where?

                  I dont require a username and password to get into the system or access the share.
                  I did try restarting samba but that didnt help. I dont know what credentials you would be talking about since none are asked for.

                  Comment


                  • #10
                    Re: Samba Connection

                    Does net view \\mia work? How about net use * \\mia\some-share-name /u:mia\some-user-name * ?

                    -vP

                    Comment


                    • #11
                      Re: Samba Connection

                      Agree no credentials are asked for, but there may be other cached credentials affecting the connection.
                      Type "Credential Manager" in the search box to see what you have stored
                      Tom Jones
                      MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                      PhD, MSc, FIAP, MIITT
                      IT Trainer / Consultant
                      Ossian Ltd
                      Scotland

                      ** Remember to give credit where credit is due and leave reputation points where appropriate **

                      Comment


                      • #12
                        Re: Samba Connection

                        I've seen oddball problems with network shares if the time is not synchronized properly on the file server. Is that the case here? Kind of a long shot guess, but something worth spending two minutes looking at....but if I remember correctly, I was at least presented with a popup to enter a user name and password when this happened to me.

                        Comment


                        • #13
                          Re: Samba Connection

                          Somehow the user cached his credentials to ssh to that system, it caused explorer to use the same credentials for the samba share. Once I removed the credentials it worked. thanks for all your help and ideas.

                          Comment


                          • #14
                            Re: Samba Connection

                            Well done!
                            Tom Jones
                            MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                            PhD, MSc, FIAP, MIITT
                            IT Trainer / Consultant
                            Ossian Ltd
                            Scotland

                            ** Remember to give credit where credit is due and leave reputation points where appropriate **

                            Comment

                            Working...
                            X