Announcement

Collapse
No announcement yet.

Windows 7 Updates

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 7 Updates

    I have set Updates on my laptop to Download but to allow me to choose what to install. Was quite surprised and annoyed to find I had 25 updates installing when I shutdown yesterday. Has anyone else suffered from this happening? Even the Recommended Updates were installed!

    Click image for larger version

Name:	win7-updates.png
Views:	1
Size:	29.8 KB
ID:	492869
    1 1 was a racehorse.
    2 2 was 1 2.
    1 1 1 1 race 1 day,
    2 2 1 1 2

  • #2
    My settings are the same as yours, except for the main option. I leave my settings to 'Never Check for Updates', but run updates manually once a month, after we've posted to our Dev system at work. Logic: if I'm going to take the time to decide which updates I want to install, why even check, let alone download anything, if I'm going to pick & choose? That way, nothing gets past if I don't want it to. Try changing to 'Check for updates but let me choose...' and see if the updates still slip by without your saying so.
    *RicklesP*
    MSCA (2003/XP), Security+, CCNA

    ** Remember: credit where credit is due, and reputation points as appropriate **

    Comment


    • #3
      Yes, I used to see this behaviour as well. I would notice it when choosing Shutdown from the Start Menu and the Shutdown command had a Shield (I think) icon next to it. If I wanted the machine to shut down fast I'd cancel that and Alf+F4 from the Desktop so I could Shutdown without installing the updates.
      A recent poll suggests that 6 out of 7 dwarfs are not happy

      Comment


      • #4
        I think that's the normal behavior. If the updates have been downloaded then the shutdown menu adds the "Install Updates and Shutdown" option. I don't think it's negated by your option to notify for installation.

        Comment


        • #5
          Thanks guys.

          The reasoning behind downloading and then selecting the Updates was a slowish Internet connection. It would mean not having to wait for the downloads to finish and then having them install. I have changed the Update setting as suggested. Still annoying that the above option in the image shown, doesn't do as it says.

          [Edited to make the last sentence comprehensible]
          Last edited by biggles77; 11th September 2015, 21:27.
          1 1 was a racehorse.
          2 2 was 1 2.
          1 1 1 1 race 1 day,
          2 2 1 1 2

          Comment


          • #6
            If you want rid of that menu, open your PCs Local Policy editor, drill down to User Configuration|Administrative Templates|Windows Components|Windows Updates, look for 'Do not display 'Install Updates...'. Set that policy to ENABLED and refresh/reboot. That option is gone.
            *RicklesP*
            MSCA (2003/XP), Security+, CCNA

            ** Remember: credit where credit is due, and reputation points as appropriate **

            Comment

            Working...
            X