No announcement yet.

Windows 7 / RDP

  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 7 / RDP

    So suddenly RDP isn't working properly on my Win 7 box. It had been fine for a while, but now I am getting a strange connection problem - my server (Windows Server 2003) accepts RDP connections at a different port, say 4000. When (from my win 7 box) I try to connect to, I immediately get a message saying:

    "This computer can't connect to the remote computer. Try connecting again, if the problem continues contact the administrator"

    If I try any other port, or no port at all, along with the IP address, the computer attempts to connect (window pops up, says "initializing", progress bar goes across) and then I get an error message:

    "RDP can't connect for one of these reasons" followed by the 3 reasons.

    That is expected. I don't know why, when I specify the correct port, I instantaneously get the cannot connect message.

    These are the only things I can think of that have changed since I was able to use it as expected:

    -Installed Dell Resource CD
    -Installed Intel Graphics Media Accelerator Driver
    -Installed Dell touchpad driver
    -Installed audio driver
    -Configured GPO for folder redirection only

    I've removed the touchpad driver, resource CD, audio driver and Intel GMA driver. However, the Intel GMA driver is still in the program list, and I can't seem to get rid of it. None of this has helped.

    I've verified that RDP services (4 of them) are all running, and I've also allowed RDP Program in Windows Firewall (wasn't specified prior). I've also tried it from Windows XP mode, with the same result.

    Any help?

  • #2
    Re: Windows 7 / RDP server seems to be the problem, any mod feel free to delete this post...sorry.