No announcement yet.

Windows 7 Printing and a 2k3 Domain

  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 7 Printing and a 2k3 Domain

    I hope I aint the only one here but we have windows 7 32bit connecting to lots of network printers and 99% are the same model dotted around the place.

    Now the 2K3 server is not the X64 edition and all the drivers on there work for our old xp clients....

    some of the printers will happily connect to windows 7 some wont with the 0x0000007e error. Which is bizarre as they all use the same driver and same model of printer.

    My windows 7 machine will connect to all printers the one next to me refuses to connect to all but two its really odd...

    HP4100 using HP 4100 Series PCL 5e

    So any ideas ?

  • #2
    Re: Windows 7 Printing and a 2k3 Domain

    What driver is on the print server? AFAIK, there's no Vista, W2K8, or 7 driver for the 4100 series printers. Try installing and using the HP universal print driver on the print server.


    • #3
      Re: Windows 7 Printing and a 2k3 Domain

      I've had to use the Universal driver a few times. Usually after the first print it will detect the printer and install a driver and work fine after that, even when what the HP website says is the correct driver fails to install.
      BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
      Cruachan's Blog


      • #4
        Re: Windows 7 Printing and a 2k3 Domain

        It's possible that the printer you are attempting to connect to is not compatible with Windows 7. I would check with the Windows 7 Compatibility Center just to be sure. The Windows 7 Compatibility Center can be found at the following link:

        Microsoft Windows Client Team
        Last edited by Wired; 21st December 2009, 22:51. Reason: fixed link


        • #5
          Re: Windows 7 Printing and a 2k3 Domain


          I have the same problem with a Canon 2880 multifunctional.
          I have the right driver but when the Windows 7 Machine ( 32Bits )want to connects it gives the error 0x0000007e.

          When I delete the driver on the laptop and then try to connect again the laptop is installing the driver but unable to mak the connection.
          The rights on the W2k3 are correct.

          Who knows the answer?


          Regards Bart