Announcement

Collapse
No announcement yet.

Internet connection share for 2 WinXP Pro workstations

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Internet connection share for 2 WinXP Pro workstations

    Hello all,
    This is fairly simple issue, which I have not been able to sort out for some reason. I have 2 PC's running WinXP Pro+Sp1. 1 of them which has a broadband connection (ADSL) which I wish to share. I also a NIC on each workstation connected with a crossed network cable, connecting the 2 PC's together. The cable is fine.
    I have tried going through some tutorials on the web and only once I succeeded in sharing the connection properly. But since then I could not do it again. Seems like the connection share is lost after I restart the computer. Dont have a clue why.
    Considering this configuration, can someone here please assist me in making the connection share work, as it should...?

    Thank-you.
    If it working... don't touch it...!

  • #2
    Assume ComputerA has broadband and B does not

    On computer A
    Open control panel - network connections
    Find the ADSL connection icon and right click on it, then select "properties"
    Click on "Advanced" and then tick "Internet Connection Sharing"
    Click OK etc.
    Find the Local Area Connection and right click, then select properties
    Scroll through the list until you see TCP/IP, select it then click the "properties" button
    Check both "automatic" options are selected
    Click on OK etc -- you may have to reboot


    On computer B
    Open control panel - network connections
    Find the Local Area Connection and right click, then select properties
    Scroll through the list until you see TCP/IP, select it then click the "properties" button
    Check both "automatic" options are selected

    Check computer B can browse the web

    Hope this sorts things out

    Tom
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      some questions...

      1. In Comp_A (which has the ADSL connection) do I have to enable or disable the Internet firewall of WinXP?
      2. In Comp_A in the LAN connection, do I have to specify a static IP address, something like 192.168.0.1 with the standard netmask 255.255.255.0?
      3. In Comp_B do I have to assign a static IP to the only connection there (LAN), and do I have to define the default Gateway as the Static IP of Comp_A's LAN connection?
      4. I have some old Kingston nics, which WinXP installed it's own drivers for them. Is it imperative that I install propritary drivers for these nics?

      Thanks again.
      If it working... don't touch it...!

      Comment


      • #4
        Well, my first suggestion, if you are not really a "technical" guy is just to run the wizard from Windows XP to create all the necessary parameters for you. You can find more info in the Microsoft webpage about troubleshooting, TCP/IP parameters, etc. for a home networking connection if you click here:

        http://www.microsoft.com/windowsxp/homenetworking/

        In any case, indeed, the computer connected to the internet should have a static IP address in the LAN connection. It acts as a DHCP server for the other computer, so that one must be on DHCP.

        About the built-in Windows firewall, I just disabled it in both computers since I have third party ones installed (actually, to check that your problems are not coming from there, just disable all the firewalls for testing purposes )

        For the drivers, as far as the network card works, I suppose it is OK.

        Comment


        • #5
          @liorde
          1) I would leave the firewall OFF temporarily to sort out the networking, then turn on the firewall on A only

          2) Turning on ICS will give computer A an IP of 192.168.0.1 (but Windows will take care of all the settings for you)

          3) Computer B will get a dynamic IP from A, with all settings including default gateway configured for you

          4) If windows picks up the cards and installs drivers, that should be OK


          Tom
          Tom Jones
          MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
          PhD, MSc, FIAP, MIITT
          IT Trainer / Consultant
          Ossian Ltd
          Scotland

          ** Remember to give credit where credit is due and leave reputation points where appropriate **

          Comment


          • #6
            Does not work man...!!!!!!!

            This is all because I dont drink my Ovaltine everyday...

            I am loosing my patience with this.
            Can this issue be related to the crossed cable?
            Tom, I did exactly what you said. Network setup wizard... everything!
            PC_A, gets the static IP 192.168.0.1 as you said, with Netmask 255.255.255.0 as always.
            PC_B, is configured on automatic. When I run IPCONFIG on PC_B, it has a strange IP address (not like 192.168.x.x somehting totally different) but the netmask is not 255.255.255.0 but it is 255.255.0.0... why so??
            How did PC_B come to think of this subnet?
            Anywy, no ICS is functional and no sharing is possible between the 2 PC's.
            Do you have any other ideas Tom??

            Thanks in advance.
            If it working... don't touch it...!

            Comment


            • #7
              Pablo is right

              On 2 XP-Pro machines you dont need to go in to details

              just run wisard from
              start->My network palces->set home/office network
              on ADSL computer , and set it as a server

              Then do same thing on Client computer


              You will have verry visual wisard that explains every step of the way meaning of every option

              Good Luck
              на клеточном уровне я очень занят

              Comment


              • #8
                Re: Does not work man...!!!!!!!

                Originally posted by liorde
                This is all because I dont drink my Ovaltine everyday...

                I am loosing my patience with this.
                Can this issue be related to the crossed cable?
                Tom, I did exactly what you said. Network setup wizard... everything!
                PC_A, gets the static IP 192.168.0.1 as you said, with Netmask 255.255.255.0 as always.
                PC_B, is configured on automatic. When I run IPCONFIG on PC_B, it has a strange IP address (not like 192.168.x.x somehting totally different) but the netmask is not 255.255.255.0 but it is 255.255.0.0... why so??
                How did PC_B come to think of this subnet?
                Anywy, no ICS is functional and no sharing is possible between the 2 PC's.
                Do you have any other ideas Tom??

                Thanks in advance.
                if Computer B have DHCP option enabled - it will look for DHCP server
                and if he cant find it , he assumes any IP in range 192.168.x.x with 255.255.255.0 NetMask
                на клеточном уровне я очень занят

                Comment


                • #9
                  This is the config of PC_A:
                  Windows IP Configuration

                  Ethernet adapter Local Area Connection:

                  Connection-specific DNS Suffix . :
                  IP Address. . . . . . . . . . . . : 192.168.0.1
                  Subnet Mask . . . . . . . . . . . : 255.255.255.0
                  Default Gateway . . . . . . . . . :

                  and PC_B (if I let the wizard do it's stuff):

                  Windows IP Configuration
                  Ethernet adapter Local Area Connection:
                  Connection-specific DNS Suffix . :
                  AutoconfigurationIP Address. . . . . . . . . . . . : 169.254.54.207
                  Subnet Mask . . . . . . . . . . . : 255.255.0.0
                  Default Gateway . . . . . . . . . :

                  I dont understand why this subnet on PC_B.
                  And also they cannot ping each other for this reason I asusme...
                  PC_B to PC_A -> Destination host unreachable
                  PC_A to PC_B -> Request time out...

                  Please advise... anyone.

                  Thanks.
                  If it working... don't touch it...!

                  Comment


                  • #10
                    PC B is not seeing PC A so is getting an APIPA address

                    Try setting PC B manually:

                    IP: 192.168.0.2
                    Subnet: 255.255.255.0
                    Gateway 192.168.0.1

                    and see if they can ping

                    If not, check you cable is OK

                    Tom
                    Tom Jones
                    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
                    PhD, MSc, FIAP, MIITT
                    IT Trainer / Consultant
                    Ossian Ltd
                    Scotland

                    ** Remember to give credit where credit is due and leave reputation points where appropriate **

                    Comment


                    • #11
                      Hello Tom,
                      Thank-you for the reply.
                      I noticed this odd thing. If I boot PC_B *before* PC_A. then they can ping one another successfully...
                      If it is the other way around it simply does not work. Why is this so?
                      I changed the IP settings on PC_B manually to what you suggested.
                      For now ICS works, thank god.
                      I still cannot understand why the boot order matters here...

                      Thanks all the same.
                      If it working... don't touch it...!

                      Comment


                      • #12
                        It can happend if you dont have DHCP server on Computer_A

                        If you cant finish built-in wisard of Xp-PRO , try to configure manualy

                        Or install Wingate Proxy programm:
                        on Computer_A as server and create local user with name of Computer_B

                        on Computer_B as client and remove all manual settings in network
                        configurations for connection

                        After that , boot order will be A and then B
                        на клеточном уровне я очень занят

                        Comment


                        • #13
                          how much time difference between you start computer B first, and then computer A?
                          If you run the following comman on computer B when it is started after Computer A

                          Start->run->cmd->ipconfig/release

                          wait for a couple of seconds, and then type ipconfig
                          and test the IP it should be 192.168.0.*, but make sure before all everything, that TCP/IP is selected to automatic IP on computer B.
                          Best regards,
                          Mostafa Itani

                          ** Remember to give credit where credit is due and leave reputation points where appropriate **

                          Comment


                          • #14
                            Thanks for the replies guys.
                            Very helpful.

                            I wonder if connecting the 2 PC's through a switch or a hub will fix this strange issue of boot order.

                            What do you think?
                            If it working... don't touch it...!

                            Comment


                            • #15
                              not at all. You have to remember that if you connect through a hub, you do not need a cross cable but a direct one.
                              Best regards,
                              Mostafa Itani

                              ** Remember to give credit where credit is due and leave reputation points where appropriate **

                              Comment

                              Working...
                              X