Announcement

Collapse
No announcement yet.

Persistent proxy settings in IE6

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Persistent proxy settings in IE6

    Please advise.

    I have one XPSP2 machine on which the proxy settings keeps coming back. The problem is, that it points to an old IP that is no longer in use in the company. The user (who is local admin) uses a local profile.
    This is what I've tried so far:

    * checked the domain group policys.
    * checked the local group policys.
    * checked the registry and set the 'EnableProxy' to disabled.
    * deleted the local profile.

    But everytime the user logs back in, the damn proxy is back!
    Surely there is something I've missed...

    If I can get a pointer in which direction to go from here it'd great....

    (please move post if posted in the wrong part)

  • #2
    Re: Persistent proxy settings in IE6

    Have a look at some ofthe registry keys mentioned here and see if it is mentioned in the registry

    http://www.winguides.com/registry/display.php/292/

    Is the user part of an ou that gets the proxy applied via GPO??

    Comment


    • #3
      Re: Persistent proxy settings in IE6

      Hello,
      Most probably the proxy settings come back due to applayed GP settings.
      GPs are applied in the following order:
      Local GP, Site related GPs, Domain GPs and OU GPs.
      It is very possible that there is an OU related GP with proxy settings enabled.
      The first step in your investigation is to open a command prompt and run gpresult.
      It will tell you witch GPs are applied to the computer and currently logged on user.

      Regards,
      CSaba
      Regards,
      Csaba Papp
      MCSA+messaging, MCSE, CCNA
      ...............................
      Remember to give credit where credit is due and leave reputation points where appropriate
      .................................

      Comment


      • #4
        Re: Persistent proxy settings in IE6

        Wullieb1:
        The problem is that there shouldn't be an proxy applied at all.
        This company used to have it, but since the start of 2006 they aren't using it anymore.
        I have checked the reg keys mentioned in the link, and the only place there is "ProxyEnabled=1" is for this particular user. When I log on as myself or with the admin account I don't get the proxy enabled. Neither does the user if logging on to another computer.

        CSaba:
        I'll do that and have a look.
        I thought that the GP's did write each other over, so that only the last one is applied? But if the proxy is enabled by a local GP, then it doesn't matter if the rest doesn't mentioned it?

        Thanks a lot, now I have some loose ends to pull at again...

        ::Göran

        Comment


        • #5
          Re: Persistent proxy settings in IE6

          Originally posted by netxt
          Hello,
          Most probably the proxy settings come back due to applayed GP settings.
          GPs are applied in the following order:
          Local GP, Site related GPs, Domain GPs and OU GPs.
          It is very possible that there is an OU related GP with proxy settings enabled.
          The first step in your investigation is to open a command prompt and run gpresult.
          It will tell you witch GPs are applied to the computer and currently logged on user.

          Regards,
          CSaba

          Ran the gpresult, but I can't find anything that differs from my own gpresult and I don't get the proxy enabled...

          Any more advices on where to look from here? I'm completely stuck.

          ::Göran

          Comment


          • #6
            Re: Persistent proxy settings in IE6

            maybe a loginscript who sets those keys?
            Marcel
            Technical Consultant
            Netherlands
            http://www.phetios.com
            http://blog.nessus.nl

            MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
            "No matter how secure, there is always the human factor."

            "Enjoy life today, tomorrow may never come."
            "If you're going through hell, keep going. ~Winston Churchill"

            Comment


            • #7
              Re: Persistent proxy settings in IE6

              Originally posted by GPswe
              Wullieb1:
              The problem is that there shouldn't be an proxy applied at all.
              This company used to have it, but since the start of 2006 they aren't using it anymore.
              I have checked the reg keys mentioned in the link, and the only place there is "ProxyEnabled=1" is for this particular user. When I log on as myself or with the admin account I don't get the proxy enabled. Neither does the user if logging on to another computer.


              ::Göran

              Thats why i said to check the registry to ensure that none of the setings are applied.

              Only other option is on a GPO somewhere.

              Is the user using a roaming profile??

              Have you deleted the profile manually??

              Comment


              • #8
                Re: Persistent proxy settings in IE6

                Originally posted by wullieb1
                Thats why i said to check the registry to ensure that none of the setings are applied.

                Only other option is on a GPO somewhere.

                Is the user using a roaming profile??

                Have you deleted the profile manually??
                Checked the registry, can't find any of those settings enabled.

                The user is using a local profile, and I deleted it using the "this computer/properties/adv/profiles..."

                I'll run the gpresult /Z again as soon as the user comes in, see if I can find anything more.

                Comment


                • #9
                  Re: Persistent proxy settings in IE6

                  Execute the command proxycfg in command line.
                  Can you post the results of the above command.

                  Comment


                  • #10
                    Re: Persistent proxy settings in IE6

                    Originally posted by GPswe
                    Checked the registry, can't find any of those settings enabled.

                    The user is using a local profile, and I deleted it using the "this computer/properties/adv/profiles..."

                    I'll run the gpresult /Z again as soon as the user comes in, see if I can find anything more.

                    Once you have done this are you ensuring that the folder has either been deleted or you could rename it manually thus ensuring a new "PROFILE" is created for the user.

                    Comment


                    • #11
                      Re: Persistent proxy settings in IE6

                      Originally posted by wullieb1
                      Once you have done this are you ensuring that the folder has either been deleted or you could rename it manually thus ensuring a new "PROFILE" is created for the user.
                      Yep, I deleted the remaining files manually.
                      There was something strange with this user's profile. When he logged out, the system wouldn't release his NTUSER files. They were still locked when I logged in and tried deleting the profile.
                      This was fixed using process explorer and killing the handle.

                      Comment


                      • #12
                        Re: Persistent proxy settings in IE6

                        I presume you deleted the profile while logged in as the administrator or with an account with the correct privileges and not the account you were deleting.

                        To create a new profile i would do the following.

                        1. Delete the Profile using an administrative account.
                        2. Delete the profile from System Properties.
                        3. Ensure that the profile in documents and settings has been removed completely.
                        4. Reboot the computer.
                        5. Login as affected user.

                        I've also managed to dig this up.

                        http://www.w3privacy.com/proxy_settings.html

                        Comment

                        Working...
                        X