Announcement

Collapse
No announcement yet.

Windows XP-PRO Install Shield and Windows Installer Issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows XP-PRO Install Shield and Windows Installer Issues

    02.22.2013
    Greetings- COI Preppers...

    Short BIO: Industrial Automation- Legacy PLC; HMI; Cyber Forensics; Code Rescue and backup. It is MANDATORY that I maintain my old systems: PC DOS; MS DOS; WIN 95; WIN 98; W2K; XP PRO... I work on 286 thru 486 PC's and old PLC's which are obsolete. I can get and repair parts. The CONSUMER MARKET has NO regard for maintaining the existing infrastructure. We have industrial plants with machines and processes that REQUIRE IMMEDIATE repair for the sake of PRODUCTION. Perhaps if the global bankers would loosen the noose around our collective financial necks the industrial sector could upgrade to one of their newer toys. For now we MUST maintain what we have.

    With that said, I'm fighting an ongoing issue with a Panasonic CF-30 TOUGHBOOK regarding Windows XP-PRO-SP3. Some applications won't install because of Install Shield or Windows Installer errors. I followed some of Bill Gates' Tech net advice and rendered the system useless. Ran NFTS4DOS, CHKDSK, VipreRescue, and more... finally just did a restore point to get it back.

    I usually maintain all of my laptops, then get them to a reliable point of operation then clone the disk. It is NOT AN OPTION to do the usual RE-INSTALL. The re-install is not so bad, but it takes WEEKS to re-install all of the PLC; HMI; SERVO applications for Industrial Automation. With a CLONE it also transfers the licenses as well (most of the apps for PLC Programming have licenses and they are a pain to transfer: GE-FANUC; ALLEN BRADLEY/ROCKWELL; OMRON; MITSUBISHI; FUJI; SIEMENS; TELEMECANIQUE; SCHNEIDER; MODICON; HORNER; CUTLER HAMMER; EATON; PROFACE; UNITRONICS; EXOR; TEXAS INSTRUMENTS; TOTAL CONTROL-TCP; GE-PROFICY; FANUC-CNC; AUTOMATION DIRECT; EZPANEL; BEIJERS; IDEC; MAPLE SYSTEMS; REXROTH; UNIOP; CONTROL TECHNIQUES... and more and on and on...

    It is MUCH easier to clone the drive. FIRST I need to make sure the drive has everything I need. The problem with the Toughbook:

    I installed a new hard drive, with a slip stream XP-PRO, all the way to SP-3. I have installed MOST of the apps I use. Several months ago, before I was completely satisfied with all the apps I need, Install Shield started acting up, preventing SOME apps from installing. Then yesterday (02.21.2013) I got the error regarding the Windows Installer. I followed the instructions from Bill Gates etal and rendered the laptop unusable so had to invoke a restore point to 02.19.2013. The app I was trying to install is Red Lion Crimson 3.0, never a problem on any other machine, free software as well.

    I usually get the system to where I want then clone it, put the back up drive on the shelf for any unplanned events. In fact, with CME and EMP being a threat my backups will be in Faraday enclosures for COI (Continuity Of Industry). (If "THEY" can have their COG (Continuity Of Government) plans; bunkers; 4 Billion rounds; paper civilian targets, the least we can do in my industry is have plans to rebuild the industrial sector after any event.

    ***snip***

    So, looking for other members with ideas regarding the Install Shield and Windows Installer errors. The Windows Update does not operate correctly either, so I have had to resort to downloading the Service Packs and Updates manually.

    I hope to also make some friends in the Cyber Forensics and Legacy Industrial Control Sector.

    Thanks in Advance,
    B'rone ben Y'kov
    the FORMER united states of America

  • #2
    Re: Windows XP-PRO Install Shield and Windows Installer Issues

    Could you give us a clue what the install shield errors are?
    And also please separate the problem from the name dropping as the thread is somewhat unreadable
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Windows XP-PRO Install Shield and Windows Installer Issues

      Wtf??????????

      Comment


      • #4
        Re: Windows XP-PRO Install Shield and Windows Installer Issues

        Sorry for the rant.
        To the point:
        SOME software won't install and I get one of two error messages pertaining to either Install Shield or Windows Installer.
        I think it may be related to another previous ongoing issue with Windows Update. A while back the update icon in the task tray started disappearing when clicked. So the update icon would continually keep coming back with updates ready, but when clicked disappear. I've read about other having the same problem with the Windows update. I'm thinking if I can correct that problem then the updates will perhaps solve the issue with the installer.

        Example: Red Lion Crimson software:
        Version 3- I get the error during install
        Version 2- No problem
        Version 1- No problem

        So my thinking is the installer issues are related to the date of the updates I have received.

        System: Windows XP- PRO SP-3

        Thanks in advance for any input.

        B'rone

        Comment


        • #5
          Re: Windows XP-PRO Install Shield and Windows Installer Issues

          Can you confirm you have the latest version of Windows Installer (I think it is 3.1 but will need checking)

          Are the apps you are installing certified for XP SP3?
          have you tried any compatibility settings?

          (and from the first post, is everyone and everything involved wearing their tin-foil hat correctly? )
          Tom Jones
          MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
          PhD, MSc, FIAP, MIITT
          IT Trainer / Consultant
          Ossian Ltd
          Scotland

          ** Remember to give credit where credit is due and leave reputation points where appropriate **

          Comment


          • #6
            Re: Windows XP-PRO Install Shield and Windows Installer Issues

            Greetings Ossian,

            ******* You Wrote *******
            Can you confirm you have the latest version of Windows Installer (I think it is 3.1 but will need checking)
            ******* Reply *******
            From Belarc System Report:
            Microsoft Corporation Windows Installer- Unicode Version 4.5.6001.22159
            Stirling Technologies- InstallShield Deinstaller Version 2.20.911.0
            InstallShield unInstaller Version 2.20.926.0

            I'm not sure why there are two references to Install Shield. Also not clear as to why they are referred to as "UN-INSTALLERS".

            *******
            ******* You Wrote *******
            Are the apps you are installing certified for XP SP3?
            have you tried any compatibility settings?
            ******* Reply *******
            Yes. I have three machines with XP SP3. The issues are only on the Toughbook and involve:
            Install Shield
            Windows Installer
            Windows Update
            *******
            ******* You Wrote *******
            (and from the first post, is everyone and everything involved wearing their tin-foil hat correctly? )
            ******* Reply *******
            Actually the tinfoil lining of a hat is only used if surveillance is detected. In most cases a Jammer can be used. The backups are in Faraday Cages. RFID devices are in stainless steel wallets. iPhone in stainless steel wallet or foil if on maneuvers.

            *******
            Thanks for the response.
            B'rone

            Comment


            • #7
              Re: Windows XP-PRO Install Shield and Windows Installer Issues

              More Details:
              I thought of malware and virii... I use Vipre Anti-Virus with all the current updates. I use Vipre because of their track record, technical support, and it does not slow the machines down like other brands. They have a utility called VipreRescue which is updated daily that is invoked from Safe Mode or a command prompt. Nothing malicious has been found. I also use C-CLEANER regularly. I have used Malwarebytes as well.

              Every time I have used a Microsoft tool, like Fix-It or followed the steps in any given Tech-Net guide I end up having to use a System Restore Point to get the machine back.

              Windows Update is turned off because every time I turn it back on the update icon in the task bar notifies updates are ready to install. When clicked it disappears. If I perform a restart or shutdown the system notifies me that it will install the updates then shut down. However it does NOT install the alleged updates but just shuts down or restarts, depending on my choice selection. Then when I bring the system back up it AGAIN is slow as mollasses... taking 15 minutes or more to populate the desktop. When an application is selected, like explorer.exe or whatever... it takes 5 minutes to come up. The only applications at that point which respond quickly are taskmgr.exe or ctrl-alt-del where I can then shut down, restart with the F8 key, choose safemode and do a system restore point to get the machine back to operational.

              I have downloaded all the current updates but as of yet have not determined a proper sequence or method of manually installling them. I ASSUME they should be installed in a certain order.

              A local computer repair center told me I might consider downloading XP-PRO-SP3 and re-installing it and allowing it to repair the system. They assured me it would not wipe out my existing installed applications. Until I am certain this procedure is valid I am skeptical. I don't want to lose my software or licenses if possible. If I can just get the system fully operational I will then clone the hard drive.

              Again, looking for "green light thinking" any ideas ...

              Kind Regards,

              B'rone

              Comment


              • #8
                Re: Windows XP-PRO Install Shield and Windows Installer Issues

                Even More Details:

                I forgot to mention: I also have run NTFS4DOS from a floppy and invoked CHKDSK.
                I also have run MEMTEST to check the health of the RAM. I've tried several options in Safe Mode; run CHKDSK in Windows...

                I am inclined to think the issue is some how related to a Windows Update error somewhere. The computer shop I buy parts from indicated a possibility of uninstalling some of the updates (not necessarily service packs, but security patches) and re-installing them. I haven't figured out the procedure for that yet. Certainly I will want to do restore points along the way so I can get the machine back if I lose it.

                B'rone

                Comment

                Working...
                X