Announcement

Collapse
No announcement yet.

.MSI Files Not Installing

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • .MSI Files Not Installing

    I recently just started having an issue where MSI files would not install. It stated that I did not have proper permissions (even though I am not on a network and I am the admin) or that I need to verify that the file existed.

    In order to solve the problem, I had to go into the Properties/Security tab, add SYSTEM as a user, and give it full permissions.

    Why did this issue suddenly occur? I recently quarantined & deleted a couple of viruses and I am wondering if this is related because I have never had issues installing .MSI files in the past.

    Is there a way to ensure that SYSTEM has full permissions on everything in the future so I do not need to do this manually before each install?

    Any help appreciated.

    Thanks

  • #2
    Re: .MSI Files Not Installing

    You could always try the command
    sfc /scannow
    Please remember to award reputation points if you have received good advice.
    I do tend to think 'outside the box' so others may not always share the same views.

    MCITP -W7,
    MCSA+Messaging, CCENT, ICND2 slowly getting around to.

    Comment


    • #3
      Re: .MSI Files Not Installing

      Just ran sfc /scannow and it finished without noting any sort of errors. It didn't actually say 0 errors, it just completed and I was left with the CMD open.

      Anything else to try?

      Comment


      • #4
        Re: .MSI Files Not Installing

        is it any msi in particular, or all MSI files ?
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment


        • #5
          Re: .MSI Files Not Installing

          It was all MSIs. No issue with .exe's. I added SYSTEM as a user on the MSI itself as well as the folder that it was using as a path for installation and that fixed the issue.

          Just trying to figure out why this happened and to make sure it's fully resolved

          Comment


          • #6
            Re: .MSI Files Not Installing

            Try reseting the security settings as per this: http://support.microsoft.com/default...b;en-us;313222
            Caesar's cipher - 3

            ZKHQ BRX HYHQWXDOOB GHFLSKHU WKLV BRX ZLOO UHDOLVH LW ZDV D ZDVWH RI WLPH!

            SFX JNRS FC U6 MNGR

            Comment


            • #7
              Re: .MSI Files Not Installing

              I am afraid to try that and potentially lose user access.

              Comment


              • #8
                Re: .MSI Files Not Installing

                Any error messages in the event logs? Without the logs we have nothing to go off of. To take a guess, maybe you just need to reinstall/repair the windows installer.

                Google "Windows Installer 4.5 Redistributable"

                Comment


                • #9
                  Re: .MSI Files Not Installing

                  "System" has full control on root of fixed disks drive letters with inheritable permissions. Please check that you have this entry in your root folder properties; if not, you'll have to reset permissions, as L4ndy said. If you do have, maybe someone deselected the inheritance on one of the subfolders, in which case you'll need to:
                  a. Select inherited permissions on the folder and overwrite permissions downwards the folder structure; if you have custom permissions, add them afterwards.
                  b. Simply add the system account to the folder and it *should* propagate to subfolders, but it's really up to how your NTFS permissions are configured on that folder.
                  You can try option b in any case, but not having system permissions on a root drive can hurt one day more than MSI files fail to install.
                  Regards,
                  Leonid

                  MCSE 2003, MCITP EA, VCP4.

                  Comment


                  • #10
                    Re: .MSI Files Not Installing

                    I guess the quick way to find out if the permissions are really the problem is to copy the MSI in question to your desktop and run it from there. If it works from that location, then it could be NTFS permissions on the folder it was originally in.

                    Comment


                    • #11
                      Re: .MSI Files Not Installing

                      Originally posted by ihatecomputers View Post
                      I guess the quick way to find out if the permissions are really the problem is to copy the MSI in question to your desktop and run it from there. If it works from that location, then it could be NTFS permissions on the folder it was originally in.
                      ...or it could be the whole drive. If the problem is on the whole drive, it would be better to repair it now before something worse happens. We all know the drill: you agree to live with some malfunction and then, half a year later, some software wouldn't install and you can't figure out why. This is exactly the reason to fix such things,
                      Regards,
                      Leonid

                      MCSE 2003, MCITP EA, VCP4.

                      Comment


                      • #12
                        Re: .MSI Files Not Installing

                        Okay - so how do I go ahead and check root system properties?

                        The msi's were not installing, no matter where I set the path because they kept wanting to go into Docs & Settings/Name/.... and SYSTEM had no permissions there.


                        Please advise.

                        Comment


                        • #13
                          Re: .MSI Files Not Installing

                          Go to "my computer". Check permissions on root of all drive letters that are located on physical disks, starting with the most important - C:
                          If "SYSTEM" is not there - you'll have to follow L4ndy's advice and use http://support.microsoft.com/default...b;en-us;313222
                          Regards,
                          Leonid

                          MCSE 2003, MCITP EA, VCP4.

                          Comment


                          • #14
                            Re: .MSI Files Not Installing

                            SYSTEM is listed with full permissions for the C drive. Any risks with doing the security settings restore...the last thing I want to have happen is that I suddenly can't open anything.

                            Comment


                            • #15
                              Re: .MSI Files Not Installing

                              How about the subfolders? The should inherit this permission as well. Unless someone deliberately deselected the inheritance option from a folder.
                              Regards,
                              Leonid

                              MCSE 2003, MCITP EA, VCP4.

                              Comment

                              Working...
                              X