Announcement

Collapse
No announcement yet.

Shutdown Event Tracker not always presenting.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Shutdown Event Tracker not always presenting.

    I am using Windows XP Professional workstations in a Domain environment. Due to the need to be able to diagnose production critical issues I have placed the Shutdown Event Tracker on each client, to try and stop unauthorised reboots by operators. I have no issues with this process at all. This works well in 2 out of 5 cases. If I click start/shutdown or Ctrl+Alt+Del I am presented with the Shutdown Reason UI.
    In the other cases, clicking Start/Shutdown presents me with the normal shutdown/restart/logoff dialogue box. Selecting Shutdown shuts the PC down without question. If I select Ctrl+Alt+Del it gives the Shutdown Reason UI as required.
    I have local admin rights to the PC and with my profile it works correctly all of the time even on the offending PCs, as does the Administrator profile.
    We have a generic user profile for our Mill floor PCs. It is this user name that is causing the problem on some of the PCs, and it is the user that must have it over any other user.
    On one machine I renamed the generic user profile under Documents and Settings, logged out and then back in as the Generic user to recreate the profile, incase something was in the profile causing the problem, this did not help.
    Any assistance you could give would be greatly appreciated.
    Stephen.

  • #2
    Re: Shutdown Event Tracker not always presenting.

    What rights does the Shutdown Event Tracker need???

    I'm presuming that because its working under an admin profile that the software is functioning correctly and that the problem will lie with the permissions on the PC.

    How is your system locked down???

    What happens if you use that same logon account on another machine???

    Comment


    • #3
      Re: Shutdown Event Tracker not always presenting.

      Thanks for your quick reply.

      As I mentioned the generic user account is working fine on other machines. 2 of the 5 worked on.

      Comment


      • #4
        Re: Shutdown Event Tracker not always presenting.

        So whats different on the other 3 machines???

        Have they been locked down differently??

        Comment


        • #5
          Re: Shutdown Event Tracker not always presenting.

          Thanks wullieb1

          They all should be the same. They have the same service pack. Windows has been updated. Software installs should be generally the same. I just dont get it at all.
          Is there something I can do to force the use of Ctrl+Alt+Del for shutting down and disable Start/Shutdown? It works fine on every machine this way.

          Comment


          • #6
            Re: Shutdown Event Tracker not always presenting.

            Are they all in the same OU with the same GPO's applying???

            You could remove the ability to shutdown from the task bar.

            http://support.microsoft.com/kb/313924

            Comment


            • #7
              Re: Shutdown Event Tracker not always presenting.

              Thanks again wullieb1

              Everything about these PCs should be identical, software wise.

              The kb items seems to refer to the Shutdown button at logon.

              The removal of the Start/Shutdown button would be a perfect fix but I can only do it via a Local Group Policy. Can you assist me with that please.

              Comment


              • #8
                Re: Shutdown Event Tracker not always presenting.

                Did you read the full article???

                There is a bit at the bottom that explains how to do it that from memory hides the shutdown button from the Start Menu

                To Edit the Group Policy in a Domain
                To edit a domain-wide policy to make the Shutdown button unavailable::
                Start the Active Directory Users and Computers snap-in. To do this, click Start, point to Programs, point to Administrative Tools, and then click Active Directory Users and Computers.
                In the console, right-click your domain, and then click Properties.
                Click the Group Policy tab.
                In the Group Policy Object Links box, click the group policy for which you want to apply this setting. For example, click Default Domain Policy.
                Click Edit.
                Expand User Configuration, expand Administrative Templates, and then click Start Menu & Taskbar.
                In the right pane, double-click Disable and remove the Shut Down command.
                Click Enabled, and then click OK.
                Quit the Group Policy editor, and then click OK.

                Comment


                • #9
                  Re: Shutdown Event Tracker not always presenting.

                  wullieb1

                  Yeah I read the whole article. And I apologise if I come over argumentative because it is not my meaning. But...
                  I cant make this a Domain wide change so I am looking for a local machine fix.
                  I went through the process for the local machine but what it does is grey out the Shutdown button completely - Start/Shutdown doesnt work and Ctrl+
                  Alt+Delete also does not allow access to Shutdown button. In other words there is no way to shutdown PC at all. If we could just grey out the Start/Shutdown I would be happy.

                  Comment


                  • #10
                    Re: Shutdown Event Tracker not always presenting.

                    Originally posted by resolveit View Post
                    wullieb1

                    Yeah I read the whole article. And I apologise if I come over argumentative because it is not my meaning. But...
                    I cant make this a Domain wide change so I am looking for a local machine fix.
                    I went through the process for the local machine but what it does is grey out the Shutdown button completely - Start/Shutdown doesnt work and Ctrl+
                    Alt+Delete also does not allow access to Shutdown button. In other words there is no way to shutdown PC at all. If we could just grey out the Start/Shutdown I would be happy.
                    No need to apologise.

                    No need to make domain wide changes either.

                    If it was me i'd do the following:

                    Create a new OU specifically for the affected PC's.
                    Move the affected PC's into that OU.
                    Create a new GPO with the changes outlined above.
                    Link that GPO to the new OU and it should be job done.

                    Now go to your clients and opena a command prompt and type gpupdate /force and it will pull the lates policies from the server and hopefully all the relevant changes will be made.

                    Comment

                    Working...
                    X