Announcement

Collapse
No announcement yet.

Windows Update error 0x8007F004

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows Update error 0x8007F004

    I have a bunch of XP Pro workstations on a network with multiple servers running Win2000 and W2K3. I am trying to manually run Windows update but I get an error message that it failed and the error code is 0x8007F004 which I believe is insufficient permissions. I am logged in as an administrator - Any ideas?

  • #2
    A couple of basic things:

    1) Have you looked in the event logs to try and see more detail?

    2) Internet connectivity OK, ie does it work on some machines and not others or does it fail on all of them including the server etc.. ?

    Comment


    • #3
      Nothing in the logs, internet connectivity is ok - I have read elsewhere that this is related to permissions, but all the "suggested" remedies have so far failed.

      Comment


      • #4
        give this a try.

        http://forums.petri.com/viewtopic.ph...sdset+wuauserv

        topper
        * Shamelessly mentioning "Don't forget to add reputation!"

        Comment


        • #5
          i got an error that was related to clock sync. i'm not sure this is the same problem by it worth the try.

          just check your date and time
          Good Luck

          Shai

          MCSE 2003+Security;MCSE 2003+Messaging
          HP ASE;HP AIS;HP APS

          So, from me to all of you out there, wherever you are, remember:
          the light at the end of the tunnel may be you. Good Day!

          Comment


          • #6
            Originally posted by topper
            Thanks topper, I'll give that a go when I go back to site on Friday

            Comment


            • #7
              Originally posted by shai tsanani
              i got an error that was related to clock sync. i'm not sure this is the same problem by it worth the try.

              just check your date and time
              thanks shai - I'm pretty sure the clocks are sync'd ok - but I'll double check when I go back to site.

              Comment


              • #8
                Hi,

                Here I found some 'accepted' solutions;
                http://support.microsoft.com/newsgro...7-52b5d98d0051

                give it a try

                \Remco

                This posting is provided "AS IS" with no warranties, and confers no rights.

                __________________

                ** Remember to give credit where credit's due **
                and leave Reputation Points for meaningful posts

                Comment


                • #9
                  Thanks Rems - I have tried that solution without success. I'll update this thread tomorrow when I go back to site.

                  Comment


                  • #10
                    Originally posted by Davej
                    Originally posted by topper
                    Thanks topper, I'll give that a go when I go back to site on Friday
                    Unfortunately that didn't work topper, I'm going to get a hammer!!

                    Comment


                    • #11
                      Originally posted by Davej

                      Unfortunately that didn't work topper, I'm going to get a hammer!!
                      I think that a HUMMER will be much better in doing the job...

                      :P
                      Cheers,

                      Daniel Petri
                      Microsoft Most Valuable Professional - Active Directory Directory Services
                      MCSA/E, MCTS, MCITP, MCT

                      Comment


                      • #12
                        hehe - my next attempt is to take my test workstation off the network, login as local admin and use XP Autopatcher to load updates.

                        http://www.autopatcher.com/

                        If this works then I have narrowed down the area to look, it would point to a policy setting somewhere - it will just narrow those circles that I'm going around in

                        Comment


                        • #13
                          Ok, update time.

                          The autopatcher option didn't work. So I thought I'd modify the default domain controller policy. Now we have two logins that we use for administration, lets call them admin1 and admin2. I explicitly added admin1 to the following settings under Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment

                          Backup files and directories
                          Debug programs
                          Restore files and directories
                          Take ownership of files or other objects

                          Each of these settings already had the administrators group set, both admin1 and admin2 are in the administrators group.

                          Ran gpupdate /force

                          I logged onto my test workstation as admin2 (should have been admin1 but I made a mistake) and ran windows update - successfully! Ok now I'm confused.

                          I removed admin1 from the settings above, ran a gpupdate /force and logged into another test workstation as admin2 and ran a windows update successfully.

                          What happened? Effectively the GP is back where it was when I started and yet it now works - this is having a serious impact on my sanity, or lack thereof

                          Comment


                          • #14
                            AAAAAAAAAAAAAARRRRRRRRRRRRRGGGGGGGGGGGGGGGGHHHHHHH HHHHHHHHH!!!!!!

                            That's better.

                            So now I download SP2 for XP to install on my test workstation. I run the executable and get an error that I do not have permission to update windows XP.

                            I run gpedit.msc on the workstation and have the following settings

                            Backup files and directories - *S-1-5-32-548
                            Debug programs - Administrators
                            Restore files and directories - Administrators
                            Take ownership of files or other objects - Administrators

                            It looks like the first setting is causing the problem. I have added the admin user directly to this setting again and run a gpudate /force but it still doesn't seem to want to happen.

                            Any ideas?

                            Comment

                            Working...
                            X