Announcement

Collapse
No announcement yet.

No process listening on port 445

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • No process listening on port 445

    Hi!

    I have the following problem on just one computer (Windows XP SP3):

    net use * \\<ip>\<share> /u:<user> <pass>

    produces "Error 67 - Network path not found". Works ok on all other computers.

    It seems that SMB is not served on port 445, i.e.

    netstat -an

    on the "bad" computer shows no activity on port 445 ("UDP 0.0.0.0:445 *:*", or
    "TCP 0.0.0.0:445 0.0.0.0.:0" rsp. don't even show up).

    The mapping - for security reasons - has to be made via CIFS (DMZ, Firewall).

    Actions so far:

    1) Reinstalled TCP/IP
    2) Checked HKLM\System\CurrentControlSet\Services\NetBT\Param eters\TransportBindName
    => value is correct with "\Device\"
    3) Checked settings under WINS tab => CIFS is allowed (NetbiosOptions = 0)
    4) Client for Microsoft Network is installed and running
    5) No errors in the event log.

    Any ideas?

    Axel

  • #2
    Re: No process listening on port 445

    Can you post a ipconfig /all ?
    Caesar's cipher - 3

    ZKHQ BRX HYHQWXDOOB GHFLSKHU WKLV BRX ZLOO UHDOLVH LW ZDV D ZDVWH RI WLPH!

    SFX JNRS FC U6 MNGR

    Comment


    • #3
      Re: No process listening on port 445

      Thanks for your interest:

      ipconfig /all shows:

      Windows-IP-Konfiguration

      Hostname. . . . . . . . . . . . . : jwe_pc
      Primäres DNS-Suffix . . . . . . . : cipsi.lan
      Knotentyp . . . . . . . . . . . . : Unbekannt
      IP-Routing aktiviert. . . . . . . : Nein
      WINS-Proxy aktiviert. . . . . . . : Ja
      DNS-Suffixsuchliste . . . . . . . : cipsi.lan

      Ethernetadapter LAN-Verbindung:

      Verbindungsspezifisches DNS-Suffix:
      Beschreibung. . . . . . . . . . . : Intel(R) PRO/100 VE Network Connection
      Physikalische Adresse . . . . . . : 00-0C-F1-AA-C3-2D
      DHCP aktiviert. . . . . . . . . . : Nein
      IP-Adresse. . . . . . . . . . . . : 192.168.9.61
      Subnetzmaske. . . . . . . . . . . : 255.255.255.0
      Standardgateway . . . . . . . . . : 192.168.9.2
      DNS-Server. . . . . . . . . . . . : 192.168.9.1
      Primärer WINS-Server. . . . . . . : 192.168.9.22


      netstat -an shows:

      Aktive Verbindungen

      Proto Lokale Adresse Remoteadresse Status
      TCP 0.0.0.0:135 0.0.0.0:0 ABHÖREN
      TCP 0.0.0.0:44080 0.0.0.0:0 ABHÖREN
      TCP 0.0.0.0:44110 0.0.0.0:0 ABHÖREN
      TCP 127.0.0.1:1497 127.0.0.1:1498 HERGESTELLT
      TCP 127.0.0.1:1498 127.0.0.1:1497 HERGESTELLT
      TCP 127.0.0.1:1509 127.0.0.1:1510 HERGESTELLT
      TCP 127.0.0.1:1510 127.0.0.1:1509 HERGESTELLT
      TCP 127.0.0.1:1512 127.0.0.1:1513 HERGESTELLT
      TCP 127.0.0.1:1513 127.0.0.1:1512 HERGESTELLT
      TCP 127.0.0.1:44110 127.0.0.1:1686 WARTEND
      TCP 192.168.9.61:139 0.0.0.0:0 ABHÖREN
      TCP 192.168.9.61:139 192.168.9.52:1094 HERGESTELLT
      TCP 192.168.9.61:1488 192.168.9.29:139 HERGESTELLT
      TCP 192.168.9.61:1496 192.168.9.33:139 HERGESTELLT
      TCP 192.168.9.61:1504 192.168.10.2:8779 HERGESTELLT
      TCP 192.168.9.61:1505 192.168.10.2:5432 HERGESTELLT
      TCP 192.168.9.61:1670 192.168.9.2:8081 SCHLIESSEN_WARTEN
      TCP 192.168.9.61:1690 192.168.9.2:8081 HERGESTELLT
      TCP 192.168.9.61:1703 192.168.9.2:8081 HERGESTELLT
      TCP 192.168.9.61:1704 192.168.9.2:8081 HERGESTELLT
      TCP 192.168.9.61:1705 192.168.9.21:139 HERGESTELLT
      UDP 0.0.0.0:500 *:*
      UDP 0.0.0.0:4500 *:*
      UDP 127.0.0.1:1900 *:*
      UDP 192.168.9.61:137 *:*
      UDP 192.168.9.61:138 *:*
      UDP 192.168.9.61:1900 *:*


      simili

      Comment


      • #4
        Re: No process listening on port 445

        No ideas anyone?

        Comment


        • #5
          Re: No process listening on port 445

          Kind of a Scorched Earth suggestion: Do a repair installation. While my geeky side wants to get to the bottom of the problem and understand all the gritty inner workings, my practical side likes to get off work before 10PM.
          Wesley David
          LinkedIn | Careers 2.0
          -------------------------------
          Microsoft Certifications: MCSE 2003 | MCSA:Messaging 2003 | MCITP:EA, SA, EST | MCTS: a'plenty | MCDST
          Vendor Neutral Certifications: CWNA
          Blog: www.TheNubbyAdmin.com || Twitter: @Nonapeptide || GTalk, Reader and Google+: [email protected] || Skype: Wesley.Nonapeptide
          Goofy kitten avatar photo from Troy Snow: flickr.com/photos/troysnow/

          Comment


          • #6
            Re: No process listening on port 445

            I know i need to brush up on my german, but I can see in there that your Wins proxy is enabled.
            Is there any reason for that?
            Have you configured the clients with a functioning WINS server?
            You can try disabling it in the following registry key:
            HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\NetBT\Parameters\EnableProxy

            The value in there should currently be "2"
            Try to change that to "0" and restart the PC. let us know if it works.

            Ta
            Caesar's cipher - 3

            ZKHQ BRX HYHQWXDOOB GHFLSKHU WKLV BRX ZLOO UHDOLVH LW ZDV D ZDVWH RI WLPH!

            SFX JNRS FC U6 MNGR

            Comment


            • #7
              Re: No process listening on port 445

              Hi L4ndy,

              sorry, that's a German computer .

              Thx for your input.

              However, in the course of continued testing/probing/whatever, I already changed that value to 0, to no avail...

              The WINS server configured is up and working.

              Meanwhile I consider restarting the NetBT service with shields (i.e. procmon) up .

              Greetings

              Axel
              Last edited by simili; 6th March 2009, 08:25.

              Comment

              Working...
              X