No announcement yet.

W2KPro/SP4 fails after reloading OS

  • Filter
  • Time
  • Show
Clear All
new posts

  • W2KPro/SP4 fails after reloading OS

    Hi everyone,

    After using the upgrade option of W2K, then tried installing SP4 with no avail, getting the following error message:

    "Service Pack 4 Setup encountered an error: An error in updating your system has occurred"

    According to Microsoft Article 813747, it is the Widows Installer, which causes it and should delete "MSIServer" from the registry and reinstall the Windows Installer. BUT when I tried to reinstall the Windows Installer V2, it would not run and gave the following message:

    "An unexpected error occured", which is not really helpful at all.

    I have attached the SVCPACK logfile for further help.


    Attached Files

  • #2
    Re: W2KPro/SP4 fails after reloading OS

    Do the event logs say anything? What OS have you upgraded from?
    Gareth Howells

    BSc (Hons), MBCS, MCP, MCDST, ICCE

    Any advice is given in good faith and without warranty.

    Please give reputation points if somebody has helped you.

    "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

    "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.


    • #3
      Re: W2KPro/SP4 fails after reloading OS

      Originally posted by gforceindustries View Post
      Do the event logs say anything? What OS have you upgraded from?

      It's not actually an upgrade from another OS - it's an upgrade as opposed to a clean install. What this option does is just rewrites the system files over the existing ones without changing any of the settings but it does require for the Service Pack to be reinstalled again after the OS has been refreshed.

      I've done this process many times before on the same system w/o any probs at all.

      The funny thing is by having googled this problem I came to realise lots of other people have been having a similar problem and none managed to resolve it. And I seem to be going the same way.