Announcement

Collapse
No announcement yet.

Autologon with Windows XP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Autologon with Windows XP

    I have several test machines (most are XP, some are server 2003) setup to AutoLogon using

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
    "DefaultUserName"="myTestUser"
    "DefaultDomainName"="myDomain"
    "AutoAdminLogon"="1"
    "DefaultPassword"="myPassword"

    I also created a reboot task using the task scheduler and when I drop a file in a particular folder on that machine, the machine deletes the file and reboots. I have several test scripts that are kicked off using the startup folder.

    And, for all but one pc, this works great. The machines reboot and run tests as needed, however, I have one pc that won't complete booting up until I actually login to the pc. It performs the reboot process, only it doesn't finish booting. When I logon via RDP, it continues and starts running tests. I'm kind of puzzled and not sure what to do get it to behave like the other test machines.

    any ideas?

  • #2
    Re: Autologon with Windows XP

    Check if there are in the key
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\ CurrentVersion\policies\system
    policies that might take precedence, like
    for example "disablecad"=0 , then change 0 => 1
    (of course you must configure the policy at the GPO if there is a GPO)


    \Rems
    Last edited by Rems; 28th August 2008, 20:19.

    This posting is provided "AS IS" with no warranties, and confers no rights.

    __________________

    ** Remember to give credit where credit's due **
    and leave Reputation Points for meaningful posts

    Comment


    • #3
      Re: Autologon with Windows XP

      Thank you. disablecad was in fact 0 and that particular registry key is not present on my other pcs. I'm running tests at the moment but I'll let you know if that worked. Thanks for your help!
      Last edited by wyrmwood; 28th August 2008, 20:32.

      Comment


      • #4
        Re: Autologon with Windows XP

        Originally posted by Rems View Post
        Check if there are in the key
        HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\ CurrentVersion\policies\system
        policies that might take precedence, like
        for example "disablecad"=0 , then change 0 => 1
        (of course you must configure the policy at the GPO if there is a GPO)


        \Rems
        Thanks Rems. I am still having this issue, unfortunately. I suspect that some policy is, as you mentioned, taking precedence. I'm not an IT guy, but for my test machines, I do have to set them up locally, then add them to a specific resource group in "Active Directory Users and Computers" so they don't get all the policies for the network pushed down. With this particular machine, I was replacing an old one, but it wouldn't let me use the same computer name, so I deleted the old computer name, renamed the new machine, then added it to the resource group using ADU&C. It may be that since I had it on the network at the time, policies that take precendence were pushed down.

        Thanks for your help,
        WW

        Comment


        • #5
          Re: Autologon with Windows XP

          When you say 'resource group', presumably you mean an Organisational Unit in ADUC? Ie, within the Computers OU do you have sub-groups defined for different machine groups? Group policies are applied to OUs, not to security groups.

          If this is the case, then any old policies which should no longer apply *should* be cleared during a reboot when the policies are refreshed. However sometimes this can fail for various reasons, in which case I would recommend forcing a manual update of the policies. At a Run dialog, enter the command cmd and press OK, then in the command prompt window enter the command gpupdate /force. After a pause you will be asked if it's ok to reboot, accept this and hopefully once the machine comes back up it will have updated the set of group policies which apply to it.
          Gareth Howells

          BSc (Hons), MBCS, MCP, MCDST, ICCE

          Any advice is given in good faith and without warranty.

          Please give reputation points if somebody has helped you.

          "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

          "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

          Comment


          • #6
            Re: Autologon with Windows XP

            I should point out here (for absolute clarity) that there is NO OU called "Computers" in an AD. The computers CONTAINER cannot be deleted or renamed, and you cannot create an OU with the same name. The reason I am so pedantic is that because the Computers object is a container, you CANNOT apply group policy to it or create OUs within it.


            Tom
            For my own and your protection, I do not provide support by private message under any circumstances. All such messages will be deleted and ignored.

            Anything you say will be misquoted and used against you

            Comment


            • #7
              Re: Autologon with Windows XP

              And to add to what Tom said, all computer in Active Directory will apply the Default Domain Policy as well as any other GPOs linked to the domain object (unless the OU they're in is blocking inheritance).

              Since, however, all the PCs but one don't have issues then I think the problem is not with the Group Policy. I would check the local policy to see if there's any settings there. On the computer that is having issues:

              Run \ gpedit.msc
              Regards,
              Jeremy

              Network Consultant/Engineer
              Baltimore - Washington area and beyond
              www.gma-cpa.com

              Comment


              • #8
                Re: Autologon with Windows XP

                Thanks all, I tried the "gpupdate /force" and that did not seem to correct it, so I tried comparing some of the settings with another pc that is working. After a few minutes, I decided to pull out the stops - I reimaged the pc and pulled down his configurations and all is well again.

                thanks again!

                Comment

                Working...
                X