Announcement

Collapse
No announcement yet.

XP PRO sp2 not showing 4gb & external drive issues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • XP PRO sp2 not showing 4gb & external drive issues

    hello all,
    i searched the forums for an answer but did not see anything along the lines of a fix for my issues and i will post them below. if an answer exists and i've missed it please link me to it.
    here we go...

    i've got a couple of problems going on that i can't quite solve. thought i'd borrow some knowledge from the geekier than me peeps.

    i've got a new MoBo ASUS- m2n-mx se. it only has 2 memory slots
    got 2 2gb sticks in there -
    bios reads all 4 gb of ram
    xp sp2 reads a solid 3gb

    i read online and it says that if the /noexecute=optin is in the boot.ini then that implies the /pae option meaning the physical address extention is on. but i took noexecute out and put /pae just to see if it would make a difference. still 3 gbs. any thoughts on this would be helpful


    2nd problem.

    i've got a 250 gb sata drive that is in an Sata-usb2.0 enclosure. it worked fine when i connected it to the pc but now everytime i restart my pc i have to go in disk management and "reactivate" the disk. once i do that it assigns a drive letter and off we go again. this i'm at a complete loss and have never come across before. help pweeze.

  • #2
    Re: XP PRO sp2 not showing 4gb & external drive issues

    In terms of the 3GB issue see http://www.microsoft.com/whdc/system...AE/PAEmem.mspx.
    MCSA 2000/2003

    Comment


    • #3
      Re: XP PRO sp2 not showing 4gb & external drive issues

      Also note some MoBos do not natively pick up all the RAM - I have an Asus with 4Gb -- the BIOS reports 3.25Gb, as does Windows
      Tom Jones
      MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
      PhD, MSc, FIAP, MIITT
      IT Trainer / Consultant
      Ossian Ltd
      Scotland

      ** Remember to give credit where credit is due and leave reputation points where appropriate **

      Comment


      • #4
        Re: XP PRO sp2 not showing 4gb & external drive issues

        the bios reads all 4 gb's
        it's the OS that just drops the extra 1gb

        Comment


        • #5
          Re: XP PRO sp2 not showing 4gb & external drive issues

          Is any of the memory being shared in the BIOS for anything like video, etc? Also, does the computer supoort hot-swap memory? If so, then some of the memory is being reserved for the hot-swap capability. Have you checked the vendor web site?

          Comment


          • #6
            Re: XP PRO sp2 not showing 4gb & external drive issues

            there's a pcie card in the machine. and there are 64mb allocated for onboard video
            which i might disable alltogether

            Comment


            • #7
              Re: XP PRO sp2 not showing 4gb & external drive issues

              Your first problem is that your Windows show 3GB of RAM instead of 4GB.
              The reason behind this is your motherboard takes 1GB for onboard graphics and therefore shows you only 3GB of RAM.

              I am not so sure about your second problem can you be a little more descriptive so that we can serve you better.

              Comment


              • #8
                Re: XP PRO sp2 not showing 4gb & external drive issues

                Originally posted by rtginc View Post
                Your first problem is that your Windows show 3GB of RAM instead of 4GB.
                The reason behind this is your motherboard takes 1GB for onboard graphics and therefore shows you only 3GB of RAM.

                I am not so sure about your second problem can you be a little more descriptive so that we can serve you better.
                WOW!!! A MOBO with 1 GB of integraded graphic memory? WOW!

                Not...
                Cheers,

                Daniel Petri
                Microsoft Most Valuable Professional - Active Directory Directory Services
                MCSA/E, MCTS, MCITP, MCT

                Comment


                • #9
                  Re: XP PRO sp2 not showing 4gb & external drive issues

                  Regarding the 3GB - 4GB ram problem, did you search google as well? I just hit it with "3gb ram showing 4gb installed" and got about half a million hits. Gotta be something there for you...

                  2nd problem - please give us more info, like manufacturer etc and did you search the manufacturer's site or ring them and see if they can help?
                  Best wishes,
                  PaulH.
                  MCP:Server 2003; MCITP:Server 2008; MCTS: SBS2008

                  Comment


                  • #10
                    Re: XP PRO sp2 not showing 4gb & external drive issues

                    The links have already been posted - to sum it up, a 32 bit OS has a limit of 4 GB of memory it can access / recognize / deal with - a 64 bit has a much much higher limit.

                    You can't get XP to see it all unless you upgrade to XP 64bit.
                    sigpic

                    Comment


                    • #11
                      Re: XP PRO sp2 not showing 4gb & external drive issues

                      XP won't go further then about 3.3 GB for some reason although the BIOS see the 4gb.
                      Or at least I've seen it many times and never ever got it fixed to use the full 4gb.
                      Marcel
                      Technical Consultant
                      Netherlands
                      http://www.phetios.com
                      http://blog.nessus.nl

                      MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
                      "No matter how secure, there is always the human factor."

                      "Enjoy life today, tomorrow may never come."
                      "If you're going through hell, keep going. ~Winston Churchill"

                      Comment


                      • #12
                        Re: XP PRO sp2 not showing 4gb & external drive issues

                        http://www.brianmadden.com/content/a...t-really-mean-
                        sigpic

                        Comment


                        • #13
                          Re: XP PRO sp2 not showing 4gb & external drive issues

                          Hello,
                          as for your second problem might I ask if you have a drive mapped to the letter one after your normal last physical drive letter? As in my last physical drive (CD-ROM) is E: and I have F: mapped to a share elsewhere. Sometimes if I plug a memory stick in, Windows may try and assign the drive letter F: to the memory stick but it can't as it is already assigned.
                          I suppose the way to phrase this is, is the drive letter assignment before the next free drive letter, an assignment to a network drive?
                          How is the external drive getting its power?
                          Also you say "but now everytime", has something changed?
                          I don't know anything about (you or your) computers.
                          Research/test for yourself when listening to free advice.

                          Comment

                          Working...
                          X