Announcement

Collapse
No announcement yet.

XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

    When using keyboard shortcuts to open programs via the shortcut key that you can set on a .lnk to that program, I find that my workstation can sometimes hang for around 15-20 seconds.

    Most of the time, the shortcuts work fine, but then every now and again using one will just cause everything to block and hang, everything you do in the next 20 seconds doesn't materialize on the computer until that original action is unblocked and then everything races through a catch up, like a sudden gush of released water....

    Anyone know how to fix this behaviour to not block/freeze the desktop?

  • #2
    Re: XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

    Are you never able to duplicate this when *clicking* on the shortcut on your desktop?

    Try for at least a day (I'd use a week - and I know how asinine it sounds, I hate using the mouse when I have all these wonderful KB shortcuts in HoeKey to load apps quickly) and see if it is random app loading or specifically hot key presses causing the problem.

    If you have already done this my apologies....

    I'd also take a look at using some of the sysinternals tools to see what is really going on (process monitor and Process explorer - PM for having it run in the background all the time since the lockups are unpredictable, and PE simply because it is much superior to any Task Manager for Windows, including the built in one in Windows.

    [OT] Slightly off topic, but the shortcuts in Windows don't allow you to use the [WIN] key for them, making life a bit strange and difficult- I strongly suggest you check out HoeKey, from bCheck apps at arstecnica (http://www.bcheck.net/apps/hoe.htm)

    The installer will install ver 1.13, and you'll need to download the 1.16 standalone executable and replace the one the installer placed in Program Files. *If* you're interested in trying it, that is.[/OT]
    sigpic

    Comment


    • #3
      Re: XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

      This never happens when clicking the shortcuts, they're for things like cmd etc, which should never hang on startup...

      I've noticed that when this happens, there is constant hard disk activity like windows is having to search all shortcuts on the desktop and start menu to match the keystrokes...

      Comment


      • #4
        Re: XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

        Yeah, I had already figured on some sort of a high activity period, bu it would still help if you stopped using the shortcuts for a week and seeing if the problem exists across the board (which is what I think) or if it is truly only with KB shortcuts.

        I am not saying you're wrong, I am wanting to eliminate a bigger picture here before focusing exclusively only on the hot keys, only to find out later on down the road that is *isn't* only hotkeys, but specific programs loading, or something else.
        sigpic

        Comment


        • #5
          Re: XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

          well considering the shortcuts are for things like cmd, and I used to use cmd all the time from start -> run with never a single hang that I can remember, I am convinced that it's the keyboard shortcuts that are doing this.

          So effectively, I have spent years trying to launch cmd from start -> run and only more recently used keyboard shortcuts to do the same thing, and now it is hanging.

          I'll go back to trying the start -> run way for a while and see how it goes,l but I'm convinced that this will not occur under those conditions.

          Comment


          • #6
            Re: XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

            No, I mean use the actually shortcut that you have the Hotkey associated with.

            E.g. if you have to go to Start --> Accessories --> System Tools --> CMD to get to the shortcut that has the Hotkey [CTRL] + [SHIFT] + C, then use that exact method (Start --> Accessories --> System Tools --> CMD) - not going through Start --> Run.

            I am wondering if the *shortcut* specifically is the cause of the problem - as in something has been changed in the way it loads, or if there is an extra parameter in the shortcut, etc. (which would manifest whether you used the hotkey or ran it from the shortcut).
            sigpic

            Comment


            • #7
              Re: XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

              err, yes sorry, I have also been using the shortcut which is on my desktop by mouse and never experienced this problem when doing that.

              EDIT: I've even created a new shortcut to cmd, no changes from the default, no parameters, no different startup directory, added the hotkey then saved it and used the hotkey. Exactly the same behaviour occurred... it hung, and all applications backed up, followed by a sudden release and jumping around of windows that I had clicked while it was hanging...
              Last edited by humbletech99; 26th December 2007, 13:42.

              Comment


              • #8
                Re: XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

                Kewl, that, at the very least, shows that the hotkey usage is causing some sort of conflict as opposed to the shortcut (assuming the shortcut you created has no problems at all independently).

                Do you have any sort of other Hotkey software that might be ruining? Have you scanned your system for Malware (in particular possible drive by key logger infections)?
                sigpic

                Comment


                • #9
                  Re: XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

                  yes, this happens on 3 systems, 1 of which has never been in contact with the other 2, and all 3 have anti-virus and anti-spyware and different vendors too...

                  Comment


                  • #10
                    Re: XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

                    OK, 3 other systems, 1 of which has never touched the other two.

                    Are you administering all 3 systems? Have you use any Group Policy changes common to all three systems not common to any other systems that you are administering?
                    sigpic

                    Comment


                    • #11
                      Re: XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

                      only 1 in is corporate environment and therefore using GPOs. I haven't set GPOs on the other 2.

                      Comment


                      • #12
                        Re: XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

                        These are machines you have access to / administer, right?

                        Any other machines you have the same rights to that don't have this problem?
                        sigpic

                        Comment


                        • #13
                          Re: XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

                          I am an admin on all 3 machines, but on the corporate one I do not run as admin, but instead runas.

                          Comment


                          • #14
                            Re: XP Pro - Using Keyboard Shortcuts sometimes hangs ~20 secs

                            Do you administer any other computers? Is there anything similar about all three other than you being the primary user (a certain set of tweaks, certain software, etc) that could be causing this? I use both an external hotkey software as well as hotkeys created through shortcuts and I never have this problem....

                            In fact, the only time I had a problem with a lengthy delay like that was with SpyBot S&D and the Teatimer executable it would make browsing slow like that for a spell, then speeds would be back to normal - then again, it would just stop, waiting for something....this happened almost completely randomly, but was directly linked to Spybot S&D's TeaTimer function. But I have never had it happen only when using hotkeys for shortcut launch.
                            sigpic

                            Comment

                            Working...
                            X