No announcement yet.

XP addicted to wn98 drive

  • Filter
  • Time
  • Show
Clear All
new posts

  • XP addicted to wn98 drive

    Hi all!!

    Here's the deal; It's a long story, but it explains how I got here. I never want to see this computer again.

    I am have a friend who, of course has no money and no knowledge, so, since I helped once, I have now become the eternal tech support for the system. Previously, this was a prepackaged eMachines system that had an OEM install of WinXP Home. The motherboard died and, of course, when I put in a new one, WinXP wanted a new CD Key, and the OEM one would no longer work. I also couldn't use the secret backup partition on the drive since, it was essentially no longer an eMachines system. After arguing with MS for over an hour, I convinced them to give me a CD Key that worked, and all was wonderful.

    Unfortunately, the machine has returned to me so crapped up with spyware that it would not function in standard or safe mode. I decided that the best thing to do was to physically remove the drive, back up the critical data to another system, reformat and reinstall, which is what I did. The problem lies in that the only XP Home disk I have was not bootable, so it had to be executed from a running OS. To provide this, I grabbed an old drive with Win98, stuck it in, and ran a clean install of XP to the other drive. The Win98 drive is mapped as C:, and the WinXP drive is mapped as D:. Several days later (after I had tracked down that blasted CD Key MS gave me again) I got everything running. When I removed the win98 drive, however, the system only boots to a "c:\>", with no real DOS functionality. If I put the Win98 drive back, it's perfectly happy. The disk management utility within XP reports drive D: (XP drive) as the boot drive, and drive C: (98 drive) as the system drive.

    My question, therefore, is:

    How do I get the system to ignore the Win98 drive (C: ), and boot straight to the WinXP drive (D: ), so I can remove the Win98 drive? Any suggestions would be greatly appreciated (and might keep me from beating my own head in with a rock)!!

  • #2
    Have you tried setting up the BIOS to boot from the D drive?
    Another option is to change this line in the BOOT.INI (hidden file in the root directory)
    This is for XP that is installed on Primary HDD in the First Partition in a folder called Windows
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S

    This is for XP that is installed on Primary HDD in the Second Partition in a folder called Windows
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOW S

    This is for XP that is installed on Primary HDD in the Second Partition in a folder called WinXP

    Get the picture. If you edit the file make sure the HIDDEN Attribute is applied when you have finished.
    Joined: 23rd December 2003
    Departed: 23rd December 2015


    • #3
      Unfortunately, no dice with the BOOT.INI. Thanks, though.


      • #4
        By no dice do you mean that you cannot find it? or by no dice do you mean that it didnt work
        Come chill at my site