Announcement

Collapse
No announcement yet.

Annoying Language Problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Annoying Language Problem

    Hi Guys,

    I have two computers which i recieved installed with legal Win XP SP2 license, both computers are from IBM.
    The problem is that on startup the Keyboard Indicator is not set to English direction but to Hebrew direction, even though Hebrew is not installed at all it's like that.
    I have no idea, one computer is part of domain, the other is not.
    No special programs are installed, Office 2003 is installed though i don't think it's the problem at all.

    On startup i need to set the direction to English, not Hebrew.

    Thanks,
    Retaliator
    Thanks & Regards

    Retaliator

    MCSA/MCSE/CCNA
    Computer Science Graduate

  • #2
    Re: Annoying Language Problem

    check if at start --> cp panel --> regional and language option --> languages TAB --> details. check the default language is set to hebrew... you can change it there...


    Yaniv F
    MCSE 2000 Done
    RHCE Done

    Comment


    • #3
      Re: Annoying Language Problem

      It's checked as on every other computer..

      Only prob on computers i got preinstalled from a local reseller you should know them and i really don't wanna reinstall whole XP for that ..

      Only problem is that auto keyboard indicator should be ENGLISH and it's not like that on those specific computers.

      Plus, even after removing HEBREW from there at all, it's still like that.

      Thanks,
      Retaliator.
      Attached Files
      Thanks & Regards

      Retaliator

      MCSA/MCSE/CCNA
      Computer Science Graduate

      Comment


      • #4
        Re: Annoying Language Problem

        Go to the "Working" machine.

        Start regedit.
        Navigate to:
        HKEY_CURRENT_USER\Keyboard Layout\Preload
        Right click, and export the file to a USB key or floppy as: preload_good.reg

        Take the file preload_good.reg to the "Bad" machine.
        Start, Run, CMD

        Type the following two lines:

        REG DELETE "HKCU\Keyboard Layout\Preload"
        regedit path_to_file:preload_good.reg

        Agree to the registry merge.
        Reboot and test.
        * Users Helping Users *
        MS-MVP Windows Networking

        Comment


        • #5
          Re: Annoying Language Problem

          Thanks a lot, i was looking for that REG key on google, but could not find exact match, will test tommorow at work and let you know.

          Another way someone recommended is using TweakUI
          http://download.microsoft.com/downlo...ertoySetup.exe

          So i have two computers with that prob, i will first test the reg key, and on the second the tweakui util and let you all know,

          Thanks again,
          Retaliator
          Thanks & Regards

          Retaliator

          MCSA/MCSE/CCNA
          Computer Science Graduate

          Comment


          • #6
            Re: Annoying Language Problem

            If you have several with the issue, you really should reset completely the effected registry areas.

            Step #1: From a machine, with all appropriate keyboard layouts installed and working properly:

            Insert a formatted floppy disk in Drive A, or change the references in the code boxes below from Drive A: to another removable drive letter.

            Copy the entire contents of the code box below into Notepad. Save the file as C:\keyboard_regs.cmd:
            Code:
            MD C:\KEYBOARD
            CD C:\KEYBOARD
            REG SAVE "HKCU\Keyboard Layout\Preload" C:PRELOADS.HIV
            REG SAVE "HKCU\Keyboard Layout\Substitutes" C:SUBSTITUTES.HIV
            REG SAVE "HKLM\System\CurrentControlSet\Control\Keyboard Layouts" C:LAYOUTS.HIV
            REM ............. The following step copies to the A: floppy drive .......
            COPY C:\KEYBOARD\*.* A:
            REM ............ The following steps cleanup the saved entries ....
            DEL /s C:\KEYBOARD\*.*
            CD \
            RD /s KEYBOARD
            Then: Start, Run, CMD C:\keyboard_regs.cmd
            Agree to any prompts

            Step #2: Bring the floppy disk to the problem machine.

            Copy the entire contents of the code box below into Notepad. Save the file as C:\keyboard_fix.cmd
            Code:
            REG RESTORE "HKCU\Keyboard Layout\Preload" A:PRELOADS.HIV
            REG RESTORE "HKCU\Keyboard Layout\Substitutes" A:SUBSTITUTES.HIV
            REG RESTORE "HKLM\System\CurrentControlSet\Control\Keyboard Layouts" A:LAYOUTS.HIV
            Start, Run, CMD C:\keyboard_fix.cmd

            Reboot and test.

            Finally, you should reset the registry entries for the Language Bar. From the keyboard of the always remarkable MS-MVP Kelly Theriot:
            http://www.kellys-korner-xp.com/xp_tweaks.htm

            Scroll down to:
            Line Number 194. Right hand side.
            Language Bar Remove - Restore

            Add this download .REG file to your floppy.

            On each problem machine:
            Double click the downloaded/saved .REG file and agree to the registry merge.
            Reboot and test.
            * Users Helping Users *
            MS-MVP Windows Networking

            Comment


            • #7
              Re: Annoying Language Problem

              Hi, and thanks for the help, i really appriciate such people!
              Anyway, the registry setting for keyboard preload is just fine on the problematic machines, so i had no point changing to the same key.

              But i solved the problem with TweakUI -> Logon -> Settings -> Keyboard and COPY NOW button.

              I wonder what this have changed..

              Thanks,
              Retaliator.
              Thanks & Regards

              Retaliator

              MCSA/MCSE/CCNA
              Computer Science Graduate

              Comment


              • #8
                Re: Annoying Language Problem

                The only thing the TweakUI setting changes is the value at HKEY_USERS\.Default

                This setting is for the keyboard settings prior to a logon. After logon the settings discussed above obtain.
                This is discussed in this Microsoft KB article:
                http://support.microsoft.com/kb/138354
                Last edited by bcastner; 12th June 2007, 15:29.
                * Users Helping Users *
                MS-MVP Windows Networking

                Comment


                • #9
                  Re: Annoying Language Problem

                  Well it worked for me this way.
                  Fixed the problem at least on one computer for sure.
                  Haven't rebooted my own pc yet..

                  Retaliator
                  Thanks & Regards

                  Retaliator

                  MCSA/MCSE/CCNA
                  Computer Science Graduate

                  Comment


                  • #10
                    Re: Annoying Language Problem

                    Okay, for those who wanna know:

                    Here is a problematic computer screen shot:

                    Click image for larger version

Name:	hebfirst.jpg
Views:	1
Size:	8.8 KB
ID:	463216

                    English should be above hebrew..

                    After removing Hebrew and adding it back it's OK on two other computers, but after Reboot it's back to the prob.

                    Trying to find out why.

                    Retaliator
                    Last edited by Retaliator; 14th June 2007, 10:15.
                    Thanks & Regards

                    Retaliator

                    MCSA/MCSE/CCNA
                    Computer Science Graduate

                    Comment


                    • #11
                      Re: Annoying Language Problem

                      Hi,

                      problem was solved after removing the hebrew language, and all the language addons, and changing all default to English, then reinstalling the language addons.

                      Retaliator.

                      Click image for larger version

Name:	123.GIF
Views:	1
Size:	16.5 KB
ID:	463279
                      Thanks & Regards

                      Retaliator

                      MCSA/MCSE/CCNA
                      Computer Science Graduate

                      Comment


                      • #12
                        Re: Annoying Language Problem

                        GR8!! I'm glad you solved the problem.
                        Thank you for updating the forum.

                        Sorin Solomon


                        In order to succeed, your desire for success should be greater than your fear of failure.
                        -

                        Comment


                        • #13
                          Re: Annoying Language Problem

                          Hi - this is the first time ever that I have seen this particular problem solved. As far as my (apparently limited) knowledge went you could change the language in which you spoke to the computer but not the language in which the computer spoke to you. Has it really changed everything - including menus and stuff - from Hebrew to English? Or was it just your input that put Hebrew first. The thread was not quite clear on the matter. Could you just make another effort and tell? Thanks - Amos

                          Comment


                          • #14
                            Re: Annoying Language Problem

                            Read the whole thread and see for your self, the problem was what langueage was the default when you have to enter the password upon login.

                            Retaliator
                            Thanks & Regards

                            Retaliator

                            MCSA/MCSE/CCNA
                            Computer Science Graduate

                            Comment

                            Working...
                            X