Announcement

Collapse
No announcement yet.

My Network Interface has disappeared!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • My Network Interface has disappeared!

    I've got an XP Sp2 virtual machine (Virtual PC 2004) that was networked and working fine. How when I start it up I can't access anything on the network so I did an ipconfig in a cmd which showed

    Windows IP Configuration

    that's it! No interfaces, no settings at all. Same in Network Connections, there are no interfaces!

    So I went to device manager and saw the network adapter which shows "Intel 21140-Based PCI Fast Ethernet Adapter (Generic)". I tried uninstalling and reinstalling it but there is still no network device showing in either Network Connections or ipconfig.

    I have rebooted but it still hasn't appeared.

    Any ideas?

  • #2
    Re: My Network Interface has disappeared!

    Just a quick thought: try How to reinstall tcp/ip which is in the Daniel Petri website.
    Best wishes,
    PaulH.
    MCP:Server 2003; MCITP:Server 2008; MCTS: SBS2008

    Comment


    • #3
      Re: My Network Interface has disappeared!

      just did that but unfortunately no change.

      Comment


      • #4
        Re: My Network Interface has disappeared!

        You can also see MS kb article 825826 How to troubleshoot missing network connections icons in Windows Server 2003 and in Windows XP which basically tells you to run these at a command prompt:

        regsvr32 netshell.dll
        regsvr32 netcfgx.dll
        regsvr32 netman.dll
        then reboot. There is other advice in there if that helps, too.
        Best wishes,
        PaulH.
        MCP:Server 2003; MCITP:Server 2008; MCTS: SBS2008

        Comment


        • #5
          Re: My Network Interface has disappeared!

          the regsvr bit didn't do it but I after that I went through every step on the page and eventually it started working.

          the Simple TCP/IP Services was not installed in Windows components under networking, although I have no idea how this could have happened since I don't remember removing it and the system was previously working and networked....



          thank you so much!

          Comment


          • #6
            Re: My Network Interface has disappeared!

            Are u using Virtual PC with sp1
            This is common problem with Virtual PC with SP1
            Cheers!!
            MCSE 2003,MCSA- Messaging 2003, VCP

            Comment


            • #7
              Re: My Network Interface has disappeared!

              Maybe try Virtual PC 2007 and see if that fixes the problem.
              1 1 was a racehorse.
              2 2 was 1 2.
              1 1 1 1 race 1 day,
              2 2 1 1 2

              Comment


              • #8
                Re: My Network Interface has disappeared!

                Um... I think it's fixed already: post #5 says it's eventually working.
                Best wishes,
                PaulH.
                MCP:Server 2003; MCITP:Server 2008; MCTS: SBS2008

                Comment


                • #9
                  Re: My Network Interface has disappeared!

                  Doh! Thanks Paul and one day I really will get new glasses.
                  1 1 was a racehorse.
                  2 2 was 1 2.
                  1 1 1 1 race 1 day,
                  2 2 1 1 2

                  Comment

                  Working...
                  X