Announcement

Collapse
No announcement yet.

Windows XP Pro and slow network traffic.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows XP Pro and slow network traffic.

    Hello, I have a message for all of you so called smart people. I have a client who was running Win98 on his 2 computers. He told me that he had no problems. We reformatted his hard drives and upgraded to Windows XP Pro on both computers. When you try to open up his Word files across the network it takes about 45 to 60 sec to open up the folder. I have tried all of the obvious fixes like disabling Netbios, automatic sharing, converting his hard drives to NTFS, even have went into the registry and changed a few entries.
    The client is an attorney and he keeps all of his documents in one directory. There are a little over 2000 word files in that one folder. I have deleted the key in the registry for RemoteNameSpace.
    He told me that it all worked fine with Win98 with that many files. Does anyone have any suggestions?

    A little side note. He is running Norton Antivirus on both computers?

  • #2
    With only 2 PCs, consider using something other than TCP/IP as the networking protocol. They probably have APIPA addresses (169.254.x.x) which get released every 5 mins in an effort to find a DHCP server. Alternatively put in fixed IPs and a hosts file entry on each PC to help improve name resolution

    Tom
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Does Norton have an option for Network scanning? If it does, disable it.
      1 1 was a racehorse.
      2 2 was 1 2.
      1 1 1 1 race 1 day,
      2 2 1 1 2

      Comment


      • #4
        Originally posted by Ossian
        With only 2 PCs, consider using something other than TCP/IP as the networking protocol. They probably have APIPA addresses (169.254.x.x) which get released every 5 mins in an effort to find a DHCP server. Alternatively put in fixed IPs and a hosts file entry on each PC to help improve name resolution

        Tom
        He uses these computers on the Internet also, so why would I use something else besides TCP/IP? They have fixed static IP addresses. I have a SMC router and DHCP is disabled and I use the 192.168.2.x address scheme. I have also disabled Universal Plug & Play on the router.

        Comment


        • #5
          First of all I would try disabling Norton on both computers, Norton might be configured in such a way that it scans all 2000 files each time you open that shared directory.

          If that doesn't work create a new empty share on your computer and copy one of the Word files into that directory. Then access that file from the other computer and see if it goes faster. If it goes faster then you know that Windows XP has problems dealing with many files in a single directory, I doubt that though.

          Have a look at your eventviewer (Start -> Run -> evenvwr) to see if some networking services fail to load.

          Have you changed anything else besides the operating system, like using new cables, moving the old cables around, another hub, etc. ? There are tools that can test the communication speed between two machines. The one I use is Netperf http://www.netperf.org. The direct download link is: ftp://ftp.cup.hp.com/dist/networking...2.1/win32/x86/.

          Its a DOS-based tool and it consists of a server and a client program. Launch the netserver-a4.exe program on the machine with the many files and on the other machine issue the following command:

          Code:
          netperf-a4 -H "remote machinename or IP-address"
          Without the quotes.

          This default test should take 10-20 seconds. After its done have a look at the throughput, on a 100 Mbps network this number should be between 85-95 (* 10^6 bits/sec). If the number is significantly lower you should inspect the nics, drivers, cables, jacks, hubs and/or switches.

          Hope this helps you narrowing down the problem.
          MCSE 2003: Security

          Comment


          • #6
            Had the Exact same problem in a XP pro enviorment, disabling norton improved the sitattion but not in full, problem was solved after h.d. died and xp and office xp was reinstalled, problem just disapeared.
            Check when u have norton disabled, if when u open up the dir with windows explorer, if its still slow.
            Also get latest office updates



            If the files are only used by 1 computer, one thing you can do is use offline files , set them up to synchronize on log on and log off, and every hour or so.
            ------------------
            -- ToR911 --
            ------------------

            Comment


            • #7
              Testing wires, routers, and NICS.

              Originally posted by Pjotr
              First of all I would try disabling Norton on both computers, Norton might be configured in such a way that it scans all 2000 files each time you open that shared directory.

              If that doesn't work create a new empty share on your computer and copy one of the Word files into that directory. Then access that file from the other computer and see if it goes faster. If it goes faster then you know that Windows XP has problems dealing with many files in a single directory, I doubt that though.

              Have a look at your eventviewer (Start -> Run -> evenvwr) to see if some networking services fail to load.

              Have you changed anything else besides the operating system, like using new cables, moving the old cables around, another hub, etc. ? There are tools that can test the communication speed between two machines. The one I use is Netperf http://www.netperf.org. The direct download link is: ftp://ftp.cup.hp.com/dist/networking...2.1/win32/x86/.

              Its a DOS-based tool and it consists of a server and a client program. Launch the netserver-a4.exe program on the machine with the many files and on the other machine issue the following command:

              Code:
              netperf-a4 -H "remote machinename or IP-address"
              Without the quotes.

              This default test should take 10-20 seconds. After its done have a look at the throughput, on a 100 Mbps network this number should be between 85-95 (* 10^6 bits/sec). If the number is significantly lower you should inspect the nics, drivers, cables, jacks, hubs and/or switches.

              Hope this helps you narrowing down the problem.
              Hello,
              I did what you suggested and when I ran the test, I got a value of .42 not even a whole number but ".42". I have a Pentascanner wire tester and I verified all of the wires and they were okay. I changed out the router and the value went up to 76.41. Still not in the range that you suggested. The computers are 2 identical Dell computers with onboard NIC cards. I am going to experiment with the NIC cards next and see if I can get it in the range that you suggested. I have a similar setup in my office and I ran the test and got 90.88.

              Comment

              Working...
              X