Announcement

Collapse
No announcement yet.

Active desktop problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Active desktop problem

    I would like to have a Desktop Wallpaper without any icons on the desktop.
    The situation
    Workstations Are XP sp2 network in a domain
    Server win 2k3

    In a new clean GPO
    Administrative templates -> Desktop -> Active desktop -> enabled Active Desktop, enabled Active desktop wallpaper set it to the right path.
    Administrative templates -> Desktop -> enabled hide and disable all items on desktop

    When i login on XP WS i do not get an active desktop wallpaper and no icons.

    But when i disable "hide and disable all items on desktop" then i get a wallpaper but then i have also the icons what i don't want.

    What can this be or what do i have more to do.

  • #2
    Re: Active desktop problem

    You may not get many hits on this as I am not aware of any commercial enterprise that uses Active Desktop. Having said that, I am interested in what you are doing with it and why you are using it.

    Back to your problem. Are you certain the GPO change has propagated to your workstation?

    http://www.microsoft.com/technet/pro...ifypolicy.mspx
    Cheers,

    Rick

    ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

    2006-2099 R Valstar. This post is offered "as is" for discussion purposes only with no express or implied warranty of any kind including, but not limited to, correctness or fitness for use. Nothing herein shall be construed as advice. Attempting any activity based on information in this post is done at your own risk.

    Comment


    • #3
      Re: Active desktop problem

      Check the file extension at the end of the UNC entered for the Active desktop.

      If the screen on the desktop goes blue, it usually means it has picked up the GPO, but doesn't know what to make of it - it's happened to me a few times!

      Comment


      • #4
        Re: Active desktop problem

        You may not get many hits on this as I am not aware of any commercial enterprise that uses Active Desktop. Having said that, I am interested in what you are doing with it and why you are using it.
        I don't know what you mean with this but i'll give an answer.

        We are a school and the students did changing the wallpaper everytime.
        We now have a costum shell XP environment without any icons on the desktop that's good. So no explorer.exe
        We work with NAL from Novell to apply the applications, what i want now is an wallpaper what views the myapps.html, that does the same as the NAL.

        It should work with it but i don't get it.

        Comment


        • #5
          Re: Active desktop problem

          A school. That explains it. Did you verify the GPO changes you made for the domain made it to the workstations? You could try to force an update from a CMD box:

          gpupdate /force /wait:-1
          The "wait:-1" means gpupdate won't return to the CMD prompt till the update is complete.

          Also, on "Enable Active Desktop", the description reads:

          Enables Active Desktop and prevents users from disabling it.

          This setting prevents users from trying to enable or disable Active Desktop while a policy controls it.

          If you disable this setting or do not configure it, Active Desktop is disabled by default, but users can enable it.

          Note: If both the "Enable Active Desktop" setting and the "Disable Active Desktop" setting are enabled, the "Disable Active Desktop" setting is ignored. If the "Turn on Classic Shell" setting ( in User Configuration\Administrative Templates\Windows Components\Windows Explorer) is enabled, Active Desktop is disabled, and both of these policies are ignored.
          Did you verify "Turn on Classic Shell" is not enabled?

          And back in the "Active Desktop" key, did you look at "Disable all items"? Don't know if that is what you want but you may try it just to verify it does something:

          Removes Active Desktop content and prevents users from adding Active Desktop content.

          This setting removes all Active Desktop items from the desktop. It also removes the Web tab from Display in Control Panel. As a result, users cannot add Web pages or pictures from the Internet or an intranet to the desktop.

          Note: This setting does not disable Active Desktop. Users can still use image formats, such as JPEG and GIF, for their desktop wallpaper.
          Just a couple of thoughts...
          Cheers,

          Rick

          ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

          2006-2099 R Valstar. This post is offered "as is" for discussion purposes only with no express or implied warranty of any kind including, but not limited to, correctness or fitness for use. Nothing herein shall be construed as advice. Attempting any activity based on information in this post is done at your own risk.

          Comment


          • #6
            Re: Active desktop problem

            For some reason there has to be something on the desktop then i get a desktopwallpaper.
            When i remove the icon then also the wallpaper is gone.

            I don't know why, cause this is first time i saw this.

            Comment


            • #7
              Re: Active desktop problem

              Did you check out the other stuff I mentioned?
              Cheers,

              Rick

              ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

              2006-2099 R Valstar. This post is offered "as is" for discussion purposes only with no express or implied warranty of any kind including, but not limited to, correctness or fitness for use. Nothing herein shall be construed as advice. Attempting any activity based on information in this post is done at your own risk.

              Comment


              • #8
                Re: Active desktop problem

                Yes i did but i won't help.
                When i not configure hide and disable all items on desktop then i get a wallpaper when set it ti enable it's gone

                strange

                Comment


                • #9
                  Re: Active desktop problem

                  I were to experiment with this tonight, what exactly is on your Active desktop wallpaper so I can try to simulate it.

                  And to confirm, you want the wallpaper and no icons, correct? And you were able to do this in the past?
                  Cheers,

                  Rick

                  ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

                  2006-2099 R Valstar. This post is offered "as is" for discussion purposes only with no express or implied warranty of any kind including, but not limited to, correctness or fitness for use. Nothing herein shall be construed as advice. Attempting any activity based on information in this post is done at your own risk.

                  Comment


                  • #10
                    Re: Active desktop problem

                    it doesn't matter what you take for a wallpaper jpg or bmp or html

                    Neither of them seems to work

                    confirmd, wallpaper no icons

                    i appreciate

                    Comment


                    • #11
                      Re: Active desktop problem

                      So here's what I found:

                      Local Computer Policy\User Configuration\Administrative Templates\Windows Components\Windows Explorer:
                      Set "Turn on Classic Shell" as "Disabled"

                      Local Computer Policy\User Configuration\Administrative Templates\Desktop:
                      Marked everything as "Enabled" EXCEPT "Hide and disable all items on the desktop". If you enable that one it does just what it says and you get no wallpaper.

                      Local Computer Policy\User Configuration\Administrative Templates\Desktop\Active Desktop:
                      Marked everything as "Enabled" EXCEPT "Disable all items", "Disable Active Desktop", "Add/Delete items", "Allow only bitmapped wallpaper"

                      "Disable all items" does just what it says (I was trying to use Google as my wallpaper).

                      Next I removed all the shortcuts the "All Users" and the local users' "Desktop" folders. I then made sure the Users group had only Read Execute on those directories.
                      You could try to remove the Desktop from the "Places" bar in as shown in the description for "Hide and disable all items on the desktop" (path in description is almost correct) but that looks like more of a pain than restricting writes on the folders.

                      Give all that a try and let me know what you still need to lock down.
                      Cheers,

                      Rick

                      ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

                      2006-2099 R Valstar. This post is offered "as is" for discussion purposes only with no express or implied warranty of any kind including, but not limited to, correctness or fitness for use. Nothing herein shall be construed as advice. Attempting any activity based on information in this post is done at your own risk.

                      Comment


                      • #12
                        Re: Active desktop problem

                        thanks i will give it a try next wednesday because i'm gone for holidays, i will report what i get

                        thanks for the research

                        Comment


                        • #13
                          Re: Active desktop problem

                          This was the trick, it's working

                          Thanks for the help.

                          Local Computer Policy\User Configuration\Administrative Templates\Desktop\Active Desktop:

                          Marked everything as "Enabled" EXCEPT "Disable all items", "Disable Active Desktop", "Add/Delete items", "Allow only bitmapped wallpaper"

                          "Disable all items" does just what it says (I was trying to use Google as my wallpaper).

                          Comment

                          Working...
                          X