Announcement

Collapse
No announcement yet.

Autologon too fast

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Autologon too fast

    Hello All:

    Iím using the AutoLogon feature in Windows XP. My goal is to have Windows XP logon and access the internet. (Iím using I.E in Kiosk mode.) The problem is that when I boot up the computer, it logs in and launches I.E. before the internet connection is ready. This causes the browser to read that the page "cannot be displayed." Should I refresh the page, it works normally, displaying the correct web page.

    My question is, is there a way to delay the Windows logon process by about 10 seconds? Iím sure that would give the computer enough time to prepare the internet connection.

    Thanks

  • #2
    Re: Autologon too fast

    Try configuring the following setting in Group Policy and see if that solves your problem.

    Computer Configuration\Administrative Templates\System\Logon\Always wait for the network at computer startup and logon
    Regards,
    Jeremy

    Network Consultant/Engineer
    Baltimore - Washington area and beyond
    www.gma-cpa.com

    Comment


    • #3
      Re: Autologon too fast

      Unfortunately, "Always wait for the network at computer startup and logon " doesn't always work. The network is "ready" in Microsoft's eyes often before it has a DHCP lease, especially on WiFi, and certainly before the Workstation service has started (not an issue for a web page but an issue for mapping drives).

      AutoLogon happens too early IMHO, not just with respect to the network but also well before things like your AV service have started. I've seen the System Tray show your AV is disabled (McAfee) or miss that icon all together.

      I had these problems as well as the original poster's problem on my son's machine when I wanted it to auto-logon and start an appropriate web page.

      My solution was to handle everything in a logon script as I was already running one already to map home, public, etc. drives (this is where I found I was having probs even w/ this option Jeremy suggested).

      So here's what I have set in my local / group computer policy:

      \Computer Configuration\Administrative Templates\System\Scripts

      Run logon scripts synchronously = Enabled

      \Computer Configuration\Administrative Templates\System\Logon

      Always wait for the network at computer startup and logon = Enabled

      \User Configuration\Administrative Templates\System\Scripts

      Run logon scripts synchronously = Enabled
      Run logon scripts visible = Enabled

      \User Configuration\Windows Settings\Scripts (Logon/Logoff)\Logon

      Script Name = cmd
      Script Parameters = /c "Logon.cmd"
      Here's the relevant bits from my Logon script in C:\WINDOWS\system32\GroupPolicy\User\Scripts\Logon (a copy of sleep.exe for the W2K Resource Kit is placed there too):

      @echo off

      rem logon.cmd

      ...

      set errflag=
      set logon_too_early=

      ...

      :net_test

      echo Verifying Network
      echo.

      for /L %%I in (1,1,10) do (
      ping %COMPUTERNAME% -n 1 | find "Reply from 127.0.0.1" > nul

      if not errorlevel 1 (
      rem Wait till a non-loopback IP occurs
      ) else (
      ping %COMPUTERNAME% -n 1 | find "Reply from "
      if not errorlevel 1 (
      net view \\%COMPUTERNAME% > nul 2> nul

      if not errorlevel 1 goto net_verified

      echo NET VIEW failed. Probably waiting on WORKSTATION service to start
      )
      )

      sleep 3

      echo Tried %%I time[s]

      set logon_too_early=Yes
      )

      echo.
      echo Error - Network not verified

      set errflag=1

      :net_verified

      ...

      if not "%errflag%"=="" (
      echo.
      echo An error occured. Exiting in 6 seconds...
      sleep 6
      ) else (
      if not "%logon_too_early%"=="" (
      echo.
      echo Waiting 6 seconds to set up System Tray...
      sleep 6
      )
      )
      Hope that helps get you on your way.
      Cheers,

      Rick

      ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

      © 2006-2099 R Valstar. This post is offered "as is" for discussion purposes only with no express or implied warranty of any kind including, but not limited to, correctness or fitness for use. Nothing herein shall be construed as advice. Attempting any activity based on information in this post is done at your own risk.

      Comment


      • #4
        Re: Autologon too fast

        Thanks for your great suggestions. I was wondering however if there was a registry entry where I could set a delay? Scripts won't work for this particular instance.

        Comment


        • #5
          Re: Autologon too fast

          I looked high and low for such a delay but could not find one.

          Why won't a logon script work for you in this case?
          Cheers,

          Rick

          ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

          © 2006-2099 R Valstar. This post is offered "as is" for discussion purposes only with no express or implied warranty of any kind including, but not limited to, correctness or fitness for use. Nothing herein shall be construed as advice. Attempting any activity based on information in this post is done at your own risk.

          Comment

          Working...
          X