No announcement yet.

Can not install any printer on my XP

  • Filter
  • Time
  • Show
Clear All
new posts

  • Can not install any printer on my XP

    Could never get printer to reinstall after uninstall my old printer. Windows makes the chime when I plug and unplug the printer but no auto detect to install. I tried to manually install the driver and the driver could not find a USB port. Also tried to install another (read different) printer and its driver could not install. A USB attached smart card reader works fine. I checked its port properties to see if a USB port was available or if I could create one. There are several ports to choose from as well as the USB. Also the add, delete, and configure buttons are greyed out so nothing can be changed or added.

    Thanks for any help...

  • #2
    Re: Can not install any printer on my XP

    How have you tried installing the drivers? Insert CD and let it run? Use Add Hardware in the Control Panel?

    Have a look in Device Manager when the printer is connected and see if there is any yellow exclamation marks next to any device. If there is an exclamation mark next to printer, insert driver CD (or unzip latest downloaded drivers to the HDD) and try to Update Driver (under the Driver tab) and get it to search for the drivers on the CD or point to their location if they are on the HDD.

    Make sure you are logged on as Administator. Is this XP Pro or Home?
    Joined: 23rd December 2003
    Departed: 23rd December 2015


    • #3
      Re: Can not install any printer on my XP

      Soudns to me like the user you're logged in as does not have admin rights. Make sure you're either logged in as a local admin to the box.




      • #4
        Re: Can not install any printer on my XP

        It happens to me too. The installation wizard doesn't detect USB port for my printer. When I plug my printer in USB printer , the system display new hardware added but not able to detect the device. The solution I device is I install printer from ADD PRINTER icon in Control pannel. During installation the wizard inform me that it is selecting port for printer but instead of selecting USB where printer is , it detect COM1. I let my system to do it with me . When wizard finish, i right click installed printer icon, select properties. In properties there is port tab. I changed port to USB from there.
        That trick is working fine with me. Try if it help you too let me know.