Announcement

Collapse
No announcement yet.

How to resolve this problem with port 445 in Windows XP?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to resolve this problem with port 445 in Windows XP?

    I have SQL Server 2000 on a Windows XP machine (testserver). If I only enable port 445, application such as ODBC administrator and Enterprise Manager cannot access testserver's port 445 from a client machine. However, I can telnet ip address 445 from the same client machine. I have \Device\ as the value of the registry TransportBindName.

    I have used TCPView to check what ports are being used. TCPView shows that the client machine is trying to establish communication with 139 even though port 445 is active but port 139 is not active.

    If I only enable port 139, those applications have no problem in accesing testserver's port 139.

    Thank you for any help.

  • #2
    Re: How to resolve this problem with port 445 in Windows XP?

    Originally posted by pcwin
    I have SQL Server 2000 on a Windows XP machine (testserver). If I only enable port 445, application such as ODBC administrator and Enterprise Manager cannot access testserver's port 445 from a client machine. However, I can telnet ip address 445 from the same client machine. I have \Device\ as the value of the registry TransportBindName.

    I have used TCPView to check what ports are being used. TCPView shows that the client machine is trying to establish communication with 139 even though port 445 is active but port 139 is not active.

    If I only enable port 139, those applications have no problem in accesing testserver's port 139.

    Thank you for any help.
    SQL Server can be configured to listen for incoming client connections in several different ways. It can be configured such that clients can use named pipes over a NetBIOS session (TCP port 139/445) or sockets with clients connecting to TCP port 1433 or both. Which ever method is used the SQL Server will always listen on UDP port 1434. This port is designated as the Microsoft SQL Monitor port and clients will send a message to this port to dynamically discover how the client should connect to the Server.
    Andrew

    ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

    Comment


    • #3
      Hi ahinson,

      I have seen port 139 being used but I have never seen port 445 being used when I use Named Pipes. When will port 445 being used for Named Pipes?

      Comment


      • #4
        Originally posted by pcwin
        Hi ahinson,

        I have seen port 139 being used but I have never seen port 445 being used when I use Named Pipes. When will port 445 being used for Named Pipes?
        Port 445 is used for RPC over TCP connections. The port might be open but the service won't listen on that port unless you make it. If you wish to use 445 you'll need to enable a reigstry key on the machine acting as the server.

        -Locate \\HKLM\SOFTWARE\Policies\Microsoft\Windows NT\RPC
        -Set the RestrictRemoteClients key = 0

        Also if you're using an application firewall make sure it's turned off (especially if you're using XP SP2 its on by default).

        Check out this article if you're still having problems.
        Andrew

        ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

        Comment


        • #5
          Hi ahinson,

          I'm not too familiar with NT Networking. You say port 445 is used for RPC over TCP connections. Does this mean port 445 is not used for Named Pipes?

          When you say that the port might be open but the "service" won't listen on that port unless you make it, which service are you referring to?


          Thank you for your help.

          Comment


          • #6
            Originally posted by pcwin
            I'm not too familiar with NT Networking. You say port 445 is used for RPC over TCP connections. Does this mean port 445 is not used for Named Pipes?
            139 and/or 445 is used for named pipes.

            Originally posted by pcwin
            When you say that the port might be open but the "service" won't listen on that port unless you make it, which service are you referring to?
            Just because the port is open doesn't mean that a program is there to handle the connection. If no program is there to connect to the port might as well be closed. That's why I gave you that registry key. Enabling it will ensure that SQL is listening on port 445.
            Andrew

            ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

            Comment


            • #7
              Hi ahinson,

              Is the registry key RestrictRemoteClients available for all Windows XP or just Windows XP SP2? I will try this when I go back to the office.

              Just to let you understand my problem better, I have the following setup:

              Windows XP SP2 RC2 (testserver) with SQL Server Personal Edition SP3a. Windows Firewall enabled with only port 445 in the exception list.

              Windows 2000 SP4 (testclient). An alias test-namedpipes for the testserver with named pipes as the network library.

              When I try to register test-namedpipes on the Enterprise Manager of the testclient, I will get error SQL Server does not exist or access denied.

              If I change the Windows Firewall to only have port 139 in the exception list, I can register test-namedpipes.

              Thank you for your help.

              Comment


              • #8
                To my knowledge it will appear on any version of XP if you've install SQL.
                Andrew

                ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

                Comment


                • #9
                  Hi ahinson,

                  It seems to me that the key is added in XP SP2:

                  http://msdn.microsoft.com/security/p...ction/rpc.aspx

                  Anyway, I will try that key on the XP SP2 RC2.

                  By the way, I have also tried using the Windows 2000 Server as the server and Windowx XP SP2 RC2 as the client. Using Named Pipes in this setup, I also see port 139 being used instead of port 445.


                  Thank you for your help.

                  Comment


                  • #10
                    Originally posted by pcwin
                    Hi ahinson,

                    It seems to me that the key is added in XP SP2.
                    That might be possible but perhaps only when SQL is present. The reason I say that is that it is not present on my machine with XP SP2 RC2. That's how I came to the conclusion that SQL puts it there.
                    Andrew

                    ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

                    Comment


                    • #11
                      Hi ahinson,

                      I will confirm this with MS and let you know.

                      Comment


                      • #12
                        Hi ahinson,

                        After I add the RestrictRemoteClients to the registry in Windows XP SP2 RC2 following the instruction in MS article 841251, I will get the message "Due to an unidentified problem, Windows cannot display Windows Firewall settings" when I try to open Windows Firewall.

                        What I have done is:

                        1. Add the key RPC under HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Win dows NT
                        2. Add the string value RestrictRemoteClients under
                        HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Win dows NT\RPC
                        3. Set the RestrictRemoteClients to 0

                        Comment


                        • #13
                          Originally posted by pcwin
                          Hi ahinson,

                          I will confirm this with MS and let you know.
                          What did MS have to say?
                          Andrew

                          ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

                          Comment


                          • #14
                            Hi ahinson,

                            I was out of the office for the last few days. I will get back to you on this one after I get the answer from MS. But based on everything I have read so far, I will say it is new and need to be added.

                            By the way, do you have an example of how I can make a RPC over TCP/IP? I want to see whether port 445 being used.

                            Comment

                            Working...
                            X